Opened 15 years ago

Closed 15 years ago

#2295 closed defect (fixed)

[with patch, positive review] build cache check fails on paths containing symlinks

Reported by: burcin Owned by: burcin
Priority: major Milestone: sage-2.10.3
Component: misc Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

GitHub link to the corresponding issue

Description

My SAGE_ROOT contains a symlinked component, upgrading from 2.10.2.alpha0 to 2.10.2 failed with the error message in this thread:

http://groups.google.com/group/sage-support/browse_thread/thread/d8ee3de015fbf7be

Only the filename listed was different.

This is caused by the module_path function in setup.py, assuming os.path.abspath starts with SAGE_ROOT, which is not the case when path contains a symlink. Attached patch fixes this issue.

Attachments (1)

build_cache_symlink.patch (712 bytes) - added by burcin 15 years ago.
fix build cache problem when sage_root has symlinks

Download all attachments as: .zip

Change History (3)

Changed 15 years ago by burcin

Attachment: build_cache_symlink.patch added

fix build cache problem when sage_root has symlinks

comment:1 Changed 15 years ago by mabshoff

I tested the patch with a non-symlinked $SAGE_ROOT and it keeps working. The problem has come up before and it is good that it has been finally fixed. Positive review.

Cheers,

Michael

comment:2 Changed 15 years ago by mabshoff

Resolution: fixed
Status: newclosed
Summary: [with patch, needs review] build cache check fails on paths containing symlinks[with patch, positive review] build cache check fails on paths containing symlinks

Merged in Sage 2.10.3.alpha0

Note: See TracTickets for help on using tickets.