Opened 2 years ago

Closed 2 years ago

#22914 closed defect (wontfix)

Symbolic products are currently broken.

Reported by: charpent Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords: symbolics
Cc: rws Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by charpent)

The symbolic product is currently broken in Sage :

  • It cannot be created in Sage :
    sage: var("j,p", domain="integer")
    sage: X,Y=function("X,Y")
    sage: prod(X(j),j,1,p)
    ---------------------------------------------------------------------------
    TypeError                                 Traceback (most recent call last)
    <ipython-input-5-85e69544cbe9> in <module>()
    ----> 1 prod(X(j),j,Integer(1),p)
    
    /usr/local/sage-8/src/sage/misc/misc_c.pyx in sage.misc.misc_c.prod (/usr/local/sage-8/src/build/cythonized/sage/misc/misc_c.c:1596)()
         69 
         70 
    ---> 71 def prod(x, z=None, Py_ssize_t recursion_cutoff=5):
         72     """
         73     Return the product of the elements in the list x.
    
    TypeError: prod() takes at most 3 positional arguments (4 given)
    sage: product(X(j),j,1,p)
    ---------------------------------------------------------------------------
    NameError                                 Traceback (most recent call last)
    <ipython-input-6-4d04d74c7489> in <module>()
    ----> 1 product(X(j),j,Integer(1),p)
    
    NameError: name 'product' is not defined
    
  • Creatnig it it by casting a Maxima expression via the library interface gives nonsense :
    sage: X(j).maxima_methods().prod(j,1,p)
    X(j)^p
    sage: X(j).maxima_methods().product(j,1,p)
    X(j)^p
    

(Note : similar nonsense also happens with sums :

sage: X(j).maxima_methods().sum(j,1,p)
p*X(j)

)

  • But something (what ?) can be created via the Maxima pexpect interface :
    sage: maxima("prod(X(j),j,1,p)").sage().log().log_expand()
    sum(log(X(j)), j, 1, p)
    

The part of the problem bound to the Maxima library interface is the object of #22920. The present ticket aims at creating a Sage function/method correctly creating a symbolic product object.

Change History (6)

comment:1 Changed 2 years ago by charpent

  • Cc rws added
  • Description modified (diff)

comment:2 follow-up: Changed 2 years ago by rws

  • Milestone changed from sage-8.0 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Duplicate of #17505.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 2 years ago by charpent

Replying to rws:

Duplicate of #17505.

Wups ! You're right. I oversaw it (and #17502 and #20179) when consulting the symbolics page.

Curiosity : why setting the status to neeeds_review ?

comment:4 in reply to: ↑ 3 Changed 2 years ago by rws

Replying to charpent:

Curiosity : why setting the status to neeeds_review ?

I want you as the ticket reporter to agree. Could you please add your ticket description to #17505?

comment:5 Changed 2 years ago by charpent

  • Status changed from needs_review to positive_review

Description pasted on #17505.

comment:6 Changed 2 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed

Closing tickets in the sage-duplicate/invalid/wontfix module with positive_review (i.e. someone has confirmed they should be closed).

Note: See TracTickets for help on using tickets.