Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#22904 closed defect (fixed)

numerical noise in sage/matrix/matrix_double_dense.pyx

Reported by: fbissey Owned by:
Priority: major Milestone: sage-8.0
Component: numerical Keywords:
Cc: strogdon Merged in:
Authors: François Bissey Reviewers: Steven Trogdon
Report Upstream: N/A Work issues:
Branch: a945232 (Commits, GitHub, GitLab) Commit:
Dependencies: Stopgaps:

Status badges

Description

I get the following doctest failures in sage-on-gentoo

sage -t --long /usr/lib64/python2.7/site-packages/sage/matrix/matrix_double_dense.pyx
**********************************************************************
File "/usr/lib64/python2.7/site-packages/sage/matrix/matrix_double_dense.pyx", line 628, in sage.matrix.matrix_double_dense.Matrix_double_dense.condition
Failed example:
    A.condition(p=Infinity)  # tol 2e-14
Expected:
    22738.50000000045
Got:
    22738.499999999945
Tolerance exceeded:
    22738.50000000045 vs 22738.499999999945, tolerance 2e-14 > 2e-14
**********************************************************************
File "/usr/lib64/python2.7/site-packages/sage/matrix/matrix_double_dense.pyx", line 1787, in sage.matrix.matrix_double_dense.Matrix_double_dense.solve_left
Failed example:
    x = A.solve_left(b); x.zero_at(1e-17) # fix noisy zeroes
Expected:
    (0.666666666..., 0.0, 0.333333333...)
Got:
    (0.6666666666666666, 1.50030138462859e-17, 0.3333333333333332)
**********************************************************************

At first I thought it was caused by a difference in openblas version but it turns out out not to be the case. Probably hardware tuning related.

This ticket will raise the tolerance of these tests a little bit to accomodate the failure

Change History (4)

comment:1 Changed 5 years ago by fbissey

  • Branch set to u/fbissey/numerical_noise_in_double_dense
  • Cc strogdon added
  • Commit set to a94523201b5af8275380ced16193cfd5bc44e471
  • Status changed from new to needs_review

Hi Steve,

would you mind reviewing this? This is fairly minor.


New commits:

a945232fix numerical noise in matrix_double_dense

comment:2 Changed 5 years ago by strogdon

  • Reviewers set to Steven Trogdon
  • Status changed from needs_review to positive_review

I suppose you get the same with vanilla. Here my SoG and vanilla are identical for the first example. There are only minor difference for the second, but no noise in the zero value. Openblas version does not seem to affect results here. I have had similar problems with this particular test in the past.

comment:3 Changed 5 years ago by vbraun

  • Branch changed from u/fbissey/numerical_noise_in_double_dense to a94523201b5af8275380ced16193cfd5bc44e471
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:4 Changed 5 years ago by chapoton

  • Authors changed from Francois Bissey to François Bissey
  • Commit a94523201b5af8275380ced16193cfd5bc44e471 deleted
Note: See TracTickets for help on using tickets.