Opened 3 years ago

Closed 3 years ago

#22868 closed enhancement (fixed)

Update Singular to 4.1.0p3

Reported by: jpflori Owned by:
Priority: major Milestone: sage-8.0
Component: packages: standard Keywords:
Cc: jakobkroeker, jdemeyer, fbissey, embray Merged in:
Authors: Jean-Pierre Flori Reviewers: François Bissey, Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: 72c3180 (Commits) Commit: 72c31808c7dcf6693596431e9ea9a454a827991e
Dependencies: Stopgaps:

Change History (14)

comment:1 Changed 3 years ago by jpflori

  • Cc jakobkroeker jdemeyer fbissey embray added
  • Status changed from new to needs_review

comment:2 Changed 3 years ago by jpflori

Currently running tests, but they passed in the most critical folders.

comment:3 Changed 3 years ago by fbissey

Hum... Here it fails its own test suite

make[3]: Leaving directory '/dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/libpolys/coeffs'
make  check-TESTS
make[3]: Entering directory '/dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/libpolys/coeffs'
make[4]: Entering directory '/dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/libpolys/coeffs'
*** Error in `/dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/libpolys/coeffs/.libs/test': free(): invalid pointer: 0x0000000000653e78 ***
======= Backtrace: =========
/lib64/libc.so.6(+0x6f263)[0x7fa2b89eb263]
/lib64/libc.so.6(+0x748d6)[0x7fa2b89f08d6]
/lib64/libc.so.6(+0x750de)[0x7fa2b89f10de]
/usr/lib64/libomalloc-0.9.6.so(omFreeSizeToSystem+0xc)[0x7fa2b968899c]
/dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/libpolys/coeffs/.libs/test(main+0x7f)[0x407a6f]
/lib64/libc.so.6(__libc_start_main+0xf0)[0x7fa2b899c790]
/dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/libpolys/coeffs/.libs/test(_start+0x29)[0x407d29]
======= Memory map: ========
00400000-00430000 r-xp 00000000 00:0e 94922367                           /dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/libpolys/coeffs/.libs/test
0062f000-00630000 r--p 0002f000 00:0e 94922367                           /dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/libpolys/coeffs/.libs/test
00630000-00631000 rw-p 00030000 00:0e 94922367                           /dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/libpolys/coeffs/.libs/test
00631000-00663000 rw-p 00000000 00:00 0                                  [heap]
7fa2b0000000-7fa2b0021000 rw-p 00000000 00:00 0 
7fa2b0021000-7fa2b4000000 ---p 00000000 00:00 0 
7fa2b753c000-7fa2b7546000 r-xp 00000000 08:04 1206898                    /usr/lib64/libgf2x.so.1.0.0
7fa2b7546000-7fa2b7746000 ---p 0000a000 08:04 1206898                    /usr/lib64/libgf2x.so.1.0.0
7fa2b7746000-7fa2b7747000 r--p 0000a000 08:04 1206898                    /usr/lib64/libgf2x.so.1.0.0
7fa2b7747000-7fa2b774a000 rw-p 0000b000 08:04 1206898                    /usr/lib64/libgf2x.so.1.0.0
7fa2b774a000-7fa2b7761000 r-xp 00000000 08:04 1217174                    /lib64/libpthread-2.23.so
7fa2b7761000-7fa2b7960000 ---p 00017000 08:04 1217174                    /lib64/libpthread-2.23.so
7fa2b7960000-7fa2b7961000 r--p 00016000 08:04 1217174                    /lib64/libpthread-2.23.so
7fa2b7961000-7fa2b7962000 rw-p 00017000 08:04 1217174                    /lib64/libpthread-2.23.so
7fa2b7962000-7fa2b7966000 rw-p 00000000 00:00 0 
7fa2b7966000-7fa2b79c7000 r-xp 00000000 08:04 3286086                    /usr/lib64/libmpfr.so.4.1.3
7fa2b79c7000-7fa2b7bc6000 ---p 00061000 08:04 3286086                    /usr/lib64/libmpfr.so.4.1.3
7fa2b7bc6000-7fa2b7bc8000 r--p 00060000 08:04 3286086                    /usr/lib64/libmpfr.so.4.1.3
7fa2b7bc8000-7fa2b7bc9000 rw-p 00062000 08:04 3286086                    /usr/lib64/libmpfr.so.4.1.3
7fa2b7bc9000-7fa2b7bdf000 r-xp 00000000 08:04 1983879                    /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libgcc_s.so.1
7fa2b7bdf000-7fa2b7dde000 ---p 00016000 08:04 1983879                    /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libgcc_s.so.1
7fa2b7dde000-7fa2b7ddf000 r--p 00015000 08:04 1983879                    /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libgcc_s.so.1
7fa2b7ddf000-7fa2b7de0000 rw-p 00016000 08:04 1983879                    /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libgcc_s.so.1
7fa2b7de0000-7fa2b7ffd000 r-xp 00000000 08:04 1348496                    /usr/lib64/libntl.so.31.0.0
7fa2b7ffd000-7fa2b81fd000 ---p 0021d000 08:04 1348496                    /usr/lib64/libntl.so.31.0.0
7fa2b81fd000-7fa2b81fe000 r--p 0021d000 08:04 1348496                    /usr/lib64/libntl.so.31.0.0
7fa2b81fe000-7fa2b8202000 rw-p 0021e000 08:04 1348496                    /usr/lib64/libntl.so.31.0.0
7fa2b8202000-7fa2b8204000 rw-p 00000000 00:00 0 
7fa2b8204000-7fa2b844a000 r-xp 00000000 08:04 1616943                    /usr/lib64/libflint.so.13.5.2
7fa2b844a000-7fa2b8649000 ---p 00246000 08:04 1616943                    /usr/lib64/libflint.so.13.5.2
7fa2b8649000-7fa2b864a000 r--p 00245000 08:04 1616943                    /usr/lib64/libflint.so.13.5.2
7fa2b864a000-7fa2b8778000 rw-p 00246000 08:04 1616943                    /usr/lib64/libflint.so.13.5.2
7fa2b8778000-7fa2b877a000 r-xp 00000000 08:04 1217199                    /lib64/libdl-2.23.so
7fa2b877a000-7fa2b897a000 ---p 00002000 08:04 1217199                    /lib64/libdl-2.23.so
7fa2b897a000-7fa2b897b000 r--p 00002000 08:04 1217199                    /lib64/libdl-2.23.so
7fa2b897b000-7fa2b897c000 rw-p 00003000 08:04 1217199                    /lib64/libdl-2.23.so
7fa2b897c000-7fa2b8b0c000 r-xp 00000000 08:04 1215154                    /lib64/libc-2.23.so
7fa2b8b0c000-7fa2b8d0b000 ---p 00190000 08:04 1215154                    /lib64/libc-2.23.so
7fa2b8d0b000-7fa2b8d0f000 r--p 0018f000 08:04 1215154                    /lib64/libc-2.23.so
7fa2b8d0f000-7fa2b8d11000 rw-p 00193000 08:04 1215154                    /lib64/libc-2.23.so
7fa2b8d11000-7fa2b8d15000 rw-p 00000000 00:00 0 
7fa2b8d15000-7fa2b8e10000 r-xp 00000000 08:04 1217171                    /lib64/libm-2.23.so
7fa2b8e10000-7fa2b900f000 ---p 000fb000 08:04 1217171                    /lib64/libm-2.23.so
7fa2b900f000-7fa2b9010000 r--p 000fa000 08:04 1217171                    /lib64/libm-2.23.so
7fa2b9010000-7fa2b9011000 rw-p 000fb000 08:04 1217171                    /lib64/libm-2.23.so
7fa2b9011000-7fa2b91f7000 r-xp 00000000 08:04 1983904                    /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libstdc++.so.6.0.21
7fa2b91f7000-7fa2b93f7000 ---p 001e6000 08:04 1983904                    /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libstdc++.so.6.0.21
7fa2b93f7000-7fa2b9404000 r--p 001e6000 08:04 1983904                    /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libstdc++.so.6.0.21
7fa2b9404000-7fa2b9408000 rw-p 001f3000 08:04 1983904                    /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libstdc++.so.6.0.21
7fa2b9408000-7fa2b940b000 rw-p 00000000 00:00 0 
7fa2b940b000-7fa2b9482000 r-xp 00000000 08:04 831588                     /usr/lib64/libgmp.so.10.3.0
7fa2b9482000-7fa2b9681000 ---p 00077000 08:04 831588                     /usr/lib64/libgmp.so.10.3.0
7fa2b9681000-7fa2b9682000 r--p 00076000 08:04 831588                     /usr/lib64/libgmp.so.10.3.0
7fa2b9682000-7fa2b9683000 rw-p 00077000 08:04 831588                     /usr/lib64/libgmp.so.10.3.0
7fa2b9683000-7fa2b968c000 r-xp 00000000 08:04 3285060                    /usr/lib64/libomalloc-0.9.6.so
7fa2b968c000-7fa2b988c000 ---p 00009000 08:04 3285060                    /usr/lib64/libomalloc-0.9.6.so
7fa2b988c000-7fa2b988d000 r--p 00009000 08:04 3285060                    /usr/lib64/libomalloc-0.9.6.so
7fa2b988d000-7fa2b988e000 rw-p 0000a000 08:04 3285060                    /usr/lib64/libomalloc-0.9.6.so
7fa2b988e000-7fa2b9893000 r-xp 00000000 08:04 3285059                    /usr/lib64/libsingular_resources-4.0.3.so
7fa2b9893000-7fa2b9a92000 ---p 00005000 08:04 3285059                    /usr/lib64/libsingular_resources-4.0.3.so
7fa2b9a92000-7fa2b9a93000 r--p 00004000 08:04 3285059                    /usr/lib64/libsingular_resources-4.0.3.so
7fa2b9a93000-7fa2b9a94000 rw-p 00005000 08:04 3285059                    /usr/lib64/libsingular_resources-4.0.3.so
7fa2b9a94000-7fa2b9c62000 r-xp 00000000 00:0e 94884332                   /dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/factory/.libs/libfactory-4.1.0.so
7fa2b9c62000-7fa2b9e61000 ---p 001ce000 00:0e 94884332                   /dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/factory/.libs/libfactory-4.1.0.so
7fa2b9e61000-7fa2b9e63000 r--p 001cd000 00:0e 94884332                   /dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/factory/.libs/libfactory-4.1.0.so
7fa2b9e63000-7fa2b9e66000 rw-p 001cf000 00:0e 94884332                   /dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/factory/.libs/libfactory-4.1.0.so
7fa2b9e66000-7fa2b9e79000 r-xp 00000000 08:04 664956                     /usr/lib64/libsandbox.so
7fa2b9e79000-7fa2ba079000 ---p 00013000 08:04 664956                     /usr/lib64/libsandbox.so
7fa2ba079000-7fa2ba07a000 r--p 00013000 08:04 664956                     /usr/lib64/libsandbox.so
7fa2ba07a000-7fa2ba07b000 rw-p 00014000 08:04 664956                     /usr/lib64/libsandbox.so
7fa2ba07b000-7fa2ba083000 rw-p 00000000 00:00 0 
7fa2ba083000-7fa2ba0a6000 r-xp 00000000 08:04 1218426                    /lib64/ld-2.23.so
7fa2ba22b000-7fa2ba270000 rw-p 00000000 00:00 0 
7fa2ba270000-7fa2ba2a6000 rw-p 00000000 00:00 0 
7fa2ba2a6000-7fa2ba2a7000 r--p 00023000 08:04 1218426                    /lib64/ld-2.23.so
7fa2ba2a7000-7fa2ba2a8000 rw-p 00024000 08:04 1218426                    /lib64/ld-2.23.so
7fa2ba2a8000-7fa2ba2a9000 rw-p 00000000 00:00 0 
7ffd9c0f4000-7ffd9c122000 rw-p 00000000 00:00 0                          [stack]
7ffd9c17f000-7ffd9c181000 r--p 00000000 00:00 0                          [vvar]
7ffd9c181000-7ffd9c183000 r-xp 00000000 00:00 0                          [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]
../../build-aux/test-driver: line 107: 27070 Aborted                 "$@" > $log_file 2>&1
FAIL: test
============================================================================
Testsuite summary for libpolys 4.0.3
============================================================================
# TOTAL: 1
# PASS:  0
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
============================================================================
See coeffs/test-suite.log
============================================================================

comment:4 Changed 3 years ago by tscrim

I was able to build on Cygwin. I did not run the test suite.

comment:5 Changed 3 years ago by fbissey

That may not be a show stopper at runtime. I suspect the test itself has a bug rather than singular has a bug. However spkg-check is run on at least some of the patchbot and that may come back to us if we just push for it.

comment:7 Changed 3 years ago by fbissey

Hum looking at the trace from the test failure, it looks like the failing test is using the wrong omalloc. Something installed from a previous version rather than the one just compiled. It probably has an influence. I guess it wouldn't matter with spkg-check since sage stupidly install before testing (OK for some software using buggy building system that's the only real way, sage itself comes to mind).

comment:8 Changed 3 years ago by fbissey

Stupid libtool bug. Sometime a system path (like /usr/lib64) is inserted in the LD_LIBRARY_PATH that is built for the test program to run. I have seen that before with octave. Not sure how to fix it. Anyway the test script set the following LD_LIBRARY_PATH:

/dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/factory/.libs:/usr/lib64:/dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/resources/.libs:/dev/shm/portage/sci-mathematics/singular-4.1.0_p3/work/singular-4.1.0/omalloc/.libs

and the /usr/lib64 in second position is the cause of the failure. Because of it libomalloc and libsinguar_resources from an installed 4.1.0_p2 are used. Of course it wouldn't happen if the sonames had been bumped.

comment:9 Changed 3 years ago by fbissey

OK I have now figured out why the test fail and it is not singular upstream's fault. Rogue installed .la file were at fault (libntl.la to be precise). So it is all clear on singular own tests.

comment:10 Changed 3 years ago by git

  • Commit changed from 85d00244d0db1cce5933bd6ee46114c58bb32fbb to 72c31808c7dcf6693596431e9ea9a454a827991e

Branch pushed to git repo; I updated commit sha1. New commits:

72c3180Better (?) solution to invert constant polynomial.

comment:11 Changed 3 years ago by jpflori

@francois: so is this good for you?

comment:12 Changed 3 years ago by fbissey

Yup. Good for the next stage.

comment:13 Changed 3 years ago by tscrim

  • Reviewers set to François Bissey, Travis Scrimshaw
  • Status changed from needs_review to positive_review

comment:14 Changed 3 years ago by vbraun

  • Branch changed from public/singular410p3 to 72c31808c7dcf6693596431e9ea9a454a827991e
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.