Opened 2 years ago

Closed 19 months ago

#22851 closed defect (fixed)

Make qepcad experimental

Reported by: vdelecroix Owned by:
Priority: blocker Milestone: sage-8.1
Component: packages: optional Keywords:
Cc: Merged in:
Authors: Vincent Delecroix Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: 25d2b68 (Commits) Commit: 25d2b689c11e47a40d4fc6ce2445ce59d28bbf6b
Dependencies: Stopgaps:

Description (last modified by vdelecroix)

On several machines qepcad is not working properly. The reported doctest errors look like

sage -t --long --warn-long 70.0 src/sage/interfaces/qepcad.py
**********************************************************************
File "src/sage/interfaces/qepcad.py", line 1565, in sage.interfaces.qepcad.?
Failed example:
    _qepcad_atoms(qepcad('(E x)[a x + b > 0]', vars='(a,b,x)'))               # optional - qepcad
Expected:
    {'a /= 0', 'b > 0'}
Got:
    {'finish  &'}
********************************************************************** 

and many other similar problems

See

Change History (17)

comment:1 Changed 2 years ago by tmonteil

I can not reproduce this (on a pretty similar setting: Debian stable, x_64, 8.0.beta2). Did you try re-compiling qepcad (just in case) ?

comment:2 Changed 2 years ago by vdelecroix

Nope. And note that the patchbot was started from scratch (ie it was a fresh build). For now I disable qepcad on quasar. I will try again later on.

comment:3 Changed 22 months ago by rws

Cannot confirm on OpenSuSE and 8.1.beta2.

comment:4 Changed 20 months ago by mderickx

  • Priority changed from major to blocker

comment:5 Changed 20 months ago by vdelecroix

I retried and the same happens with a fresh compilation of 8.1.beta8 (on quasar patchbot).

comment:6 follow-up: Changed 20 months ago by jdemeyer

I think the error might be non-deterministic. I have seen it on my patchbots too, but it does not happen every time.

My vote would be to downgrade qepcad to experimental for now.

comment:7 Changed 20 months ago by vdelecroix

Agreed if done together with a report to upstream. They might have an idea about the issue.

comment:8 in reply to: ↑ 6 Changed 20 months ago by tmonteil

Replying to jdemeyer:

I think the error might be non-deterministic. I have seen it on my patchbots too, but it does not happen every time.

Could you please provide a link to the corresponding logs, so that we can guess the common factor ?

Vincent: i am not sure to understand: you get the error systematically on that machine ? Does the doctest fail when run alone from the command line ? Could you evaluate the evolution of available RAM, dmesg, whether you ar running within a VM, etc. Perhaps this patchbot just runs out of some ressource and the finihsh is a kind of error that should just be handled by the interface.

comment:9 Changed 20 months ago by vdelecroix

I did see the error systematically while testing ticket 0 on the quasar patchbot (I did it only twice though).

The patchbot quasar has:

  • Intel i7-2600
  • 8G of RAM (+ 3G swap)
  • Ubuntu 16.04 (packages up to date)
  • tests are run in parallel with the option "parallelism": 6 of the patchbot

I am recompiling a clean 8.1.rc0 with qepcad only to see if I can reproduce.

comment:10 Changed 20 months ago by vdelecroix

It is a failure that I can reproduce on standalone tests

sage -t interfaces/qepcad.py
**********************************************************************
File "interfaces/qepcad.py", line 571, in sage.interfaces.qepcad
Failed example:
    _qepcad_atoms(qepcad(F))                                 # optional - qepcad
Expected:
    {'2 x^2 - 3 < 0', 'x > 0', 'x^2 - 3 <= 0'}
Got:
    {'finish  &'}
**********************************************************************
1 item had failures:
   1 of  71 in sage.interfaces.qepcad

    [343 tests, 1 failure, 4.22 s]
----------------------------------------------------------------------
sage -t interfaces/qepcad.py  # 1 doctest failed

And dmesg tells that there has been a segfault

[330099.427778] qepcad[23042]: segfault at 0 ip 00007f53357e0ad0 sp 00007fff03121c58 error 4 in libc-2.23.so[7f533576b000+1c0000]
[330101.201869] qepcad[23504]: segfault at 0 ip 00007f1a9db08ad0 sp 00007fffff166368 error 4 in libc-2.23.so[7f1a9da93000+1c0000]
[330101.416720] qepcad[23575]: segfault at 0 ip 00007fc35557dad0 sp 00007ffc40447278 error 4 in libc-2.23.so[7fc355508000+1c0000]
[330101.486706] qepcad[23615]: segfault at 0 ip 00007f65903e9ad0 sp 00007fff498cadc8 error 4 in libc-2.23.so[7f6590374000+1c0000]
[330105.033871] qepcad[23162]: segfault at 0 ip 00007f4d7c325ad0 sp 00007ffc5bc8baf8 error 4 in libc-2.23.so[7f4d7c2b0000+1c0000]

comment:11 follow-up: Changed 20 months ago by vbraun

  • Priority changed from blocker to major

optional packages aren't blockers, I'd say

comment:12 in reply to: ↑ 11 Changed 20 months ago by vdelecroix

Replying to vbraun:

optional packages aren't blockers, I'd say

since when!? Jeroen proposition at 6 looks reasonable to me.

comment:13 Changed 20 months ago by mderickx

Hi Volker,

Some time ago I explicitly asked about the support status for optional packages in sage on sage-devel. In that thread Jeroen answered that optional packages causing doctest failures should be considered blockers. So this is why I made this and the other ticket blocker, and no one objected to that later in the discussion. It would be helpful if you could also state your opinion on this in that sage-devel thread so that other people won't do the same in the future.

Thanks, Maarten

comment:14 Changed 19 months ago by vdelecroix

  • Authors set to Vincent Delecroix
  • Description modified (diff)
  • Milestone changed from sage-8.0 to sage-8.1
  • Priority changed from major to blocker
  • Summary changed from qepcad doctest errors to Make qepcad experimental

comment:15 Changed 19 months ago by vdelecroix

  • Branch set to u/vdelecroix/22851
  • Commit set to 25d2b689c11e47a40d4fc6ce2445ce59d28bbf6b
  • Status changed from new to needs_review

New commits:

25d2b6822851: make qepcad experimental

comment:16 Changed 19 months ago by jdemeyer

  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_review to positive_review

comment:17 Changed 19 months ago by vbraun

  • Branch changed from u/vdelecroix/22851 to 25d2b689c11e47a40d4fc6ce2445ce59d28bbf6b
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.