Opened 4 years ago

Closed 4 years ago

#22845 closed defect (duplicate)

deprecation warnings in interacts.calculus.newton_method()

Reported by: slabbe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: interact Keywords: days86
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #22636 Stopgaps:

Status badges

Description

On top of #22636, the following command

interacts.calculus.newton_method()

prints many deprecation warnings:

Precision 2h=0.001

/Users/slabbe/Applications/sage-git/local/lib/python2.7/site-packages/sage/interacts/library.py:909: DeprecationWarning:  html(...) will change soon to return HTML instead of printing it. Instead use pretty_print(html(...)) for strings or just pretty_print(...) for math. 
See http://trac.sagemath.org/18292 for details.
  html(r"$\text{Precision } 2h = %s$"%latex(float(h)))

c=1.4142141576301823

/Users/slabbe/Applications/sage-git/local/lib/python2.7/site-packages/sage/interacts/library.py:910: DeprecationWarning:  html(...) will change soon to return HTML instead of printing it. Instead use pretty_print(html(...)) for strings or just pretty_print(...) for math. 
See http://trac.sagemath.org/18292 for details.
  html(r"${c = }%s$"%c)

f(c)=1.6836416461×10−06

/Users/slabbe/Applications/sage-git/local/lib/python2.7/site-packages/sage/interacts/library.py:911: DeprecationWarning:  html(...) will change soon to return HTML instead of printing it. Instead use pretty_print(html(...)) for strings or just pretty_print(...) for math. 
See http://trac.sagemath.org/18292 for details.
  html(r"${f(c) = }%s"%latex(f(c)))

6 iterations

/Users/slabbe/Applications/sage-git/local/lib/python2.7/site-packages/sage/interacts/library.py:912: DeprecationWarning:  html(...) will change soon to return HTML instead of printing it. Instead use pretty_print(html(...)) for strings or just pretty_print(...) for math. 
See http://trac.sagemath.org/18292 for details.
  html(r"$%s \text{ iterations}"%len(midpoints))

Change History (1)

comment:1 Changed 4 years ago by jdemeyer

  • Milestone changed from sage-8.0 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22644

Note: See TracTickets for help on using tickets.