Opened 4 years ago

Closed 4 years ago

#22825 closed defect (duplicate)

Symbolic constant's interactive docs are unhelpful

Reported by: rws Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: documentation Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Symbolic constants become expressions. That's probably why this happens:

sage: NaN?
Type:           Expression
String form:    NaN
Length:         0
File:           ~/sage/local/lib/python2.7/site-packages/sage/symbolic/expression.pyx
Docstring:     
   Nearly all expressions are created by calling
...

It should be possible to get the docstring for the embedded Pyobject.

Change History (1)

comment:1 Changed 4 years ago by jdemeyer

  • Milestone changed from sage-8.0 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18077

Note: See TracTickets for help on using tickets.