Opened 5 years ago

Closed 5 years ago

#22740 closed enhancement (wontfix)

backend_polymake: Clean up imports

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: geometry Keywords:
Cc: fbissey, tscrim Merged in:
Authors: Matthias Koeppe Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Following up on #22683 comment 13, we remove redundant import statements from backend_polymake.

Change History (6)

comment:1 Changed 5 years ago by mkoeppe

  • Branch set to u/mkoeppe/backend_polymake__clean_up_imports

comment:2 Changed 5 years ago by mkoeppe

  • Authors set to Matthias Koeppe
  • Commit set to 5eee110ff62630649aac47afd2dedead320d15b3
  • Status changed from new to needs_review

Last 10 new commits:

ef23af4Polyhedron_base._polymake_init_: Add test for RDF polyhedra
205879fMatrix, MatrixSpace: Add coercion to polymake interface
e49765ePolymake: Fix tests whose error messages changed because we do not use files
51af468PolymakeElement.__iter__: New
2f0e059PolymakeElement._sage_: Implement for *Vector, *Matrix, QuadraticExtension
218dacaAdd Polyhedron_polymake
5ab94a2Merge tag '7.6' into t/22683/backend_polymake_for_polyhedron
8fd81c7Polyhedron_polymake._polymake_: Add doctest
952b860PolymakeElement.__iter__: Doc fixes
5eee110backend_polymake: Clean up imports

comment:3 Changed 5 years ago by tscrim

  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

comment:4 Changed 5 years ago by mkoeppe

  • Milestone changed from sage-8.0 to sage-duplicate/invalid/wontfix
  • Status changed from positive_review to needs_review

I've made this change part of #22740 now. Marking this as duplicate.

comment:5 Changed 5 years ago by tscrim

  • Branch u/mkoeppe/backend_polymake__clean_up_imports deleted
  • Commit 5eee110ff62630649aac47afd2dedead320d15b3 deleted
  • Dependencies #22683 deleted
  • Status changed from needs_review to positive_review

comment:6 Changed 5 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed

Closing tickets in the sage-duplicate/invalid/wontfix module with positive_review (i.e. someone has confirmed they should be closed).

Note: See TracTickets for help on using tickets.