Opened 5 years ago

Closed 5 years ago

#22695 closed enhancement (fixed)

Upgrade cysignals

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-8.0
Component: packages: standard Keywords:
Cc: vbraun Merged in:
Authors: Jeroen Demeyer Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: f11f773 (Commits, GitHub, GitLab) Commit: f11f773689833978ba9d964f5d4de9e295012555
Dependencies: Stopgaps:

Status badges

Change History (26)

comment:1 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:2 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:3 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:4 Changed 5 years ago by jdemeyer

  • Dependencies #22584 deleted

comment:5 Changed 5 years ago by jdemeyer

  • Branch set to u/jdemeyer/upgrade_cysignals

comment:6 Changed 5 years ago by jdemeyer

  • Commit set to dc9e5097cb7f1cad821f267b7e47f14bd6989024
  • Status changed from new to needs_review

New commits:

dc9e509Upgrade to cysignals version 1.5.0

comment:7 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:8 Changed 5 years ago by jdemeyer

  • Status changed from needs_review to needs_work

comment:9 Changed 5 years ago by git

  • Commit changed from dc9e5097cb7f1cad821f267b7e47f14bd6989024 to b7772d94231864404517fdc17bc6a2af83237c11

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

b7772d9Upgrade to cysignals version 1.6.0

comment:10 Changed 5 years ago by jdemeyer

  • Status changed from needs_work to needs_review

comment:11 Changed 5 years ago by jdemeyer

  • Status changed from needs_review to needs_work

Doctest failure in src/sage/repl/ipython_kernel/kernel.py

comment:12 Changed 5 years ago by git

  • Commit changed from b7772d94231864404517fdc17bc6a2af83237c11 to 3f0fc375ae85557c68d8b88674eaf68bf8b11f75

Branch pushed to git repo; I updated commit sha1. New commits:

3f0fc37Fix doctest for cysignals upgrade

comment:13 Changed 5 years ago by jdemeyer

  • Status changed from needs_work to needs_review

comment:14 Changed 5 years ago by jdemeyer

Passes all doctests.

comment:15 Changed 5 years ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

comment:16 Changed 5 years ago by vbraun

  • Status changed from positive_review to needs_work

Debug build fails with

[cysignals-1.6.0]     gcc -fno-strict-aliasing -g -O2 -g -O0 -Wall -Wno-unused -fPIC -Isrc/cysignals -Ibuild/src -Ibuild/src/cysignals -I/mnt/disk/home/buildslave-sage/slave/sage_git/build/local/include/python2.7 -c build/src/cysignals/signals.c -o build/temp.linux-x86_64-2.7-pydebug/build/src/cysignals/signals.o
[cysignals-1.6.0]     In file included from build/src/cysignals/signals.c:460:0:
[cysignals-1.6.0]     build/src/cysignals/macros.h: In function 'sig_block':
[cysignals-1.6.0]     build/src/cysignals/macros.h:243:9: warning: implicit declaration of function 'print_backtrace' [-Wimplicit-function-declaration]
[cysignals-1.6.0]              print_backtrace();
[cysignals-1.6.0]              ^~~~~~~~~~~~~~~
[cysignals-1.6.0]     In file included from build/src/cysignals/signals.c:463:0:
[cysignals-1.6.0]     build/src/cysignals/implementation.c: At top level:
[cysignals-1.6.0]     build/src/cysignals/implementation.c:72:13: warning: conflicting types for 'print_backtrace'
[cysignals-1.6.0]      static void print_backtrace(void);
[cysignals-1.6.0]                  ^~~~~~~~~~~~~~~
[cysignals-1.6.0]     build/src/cysignals/implementation.c:72:13: error: static declaration of 'print_backtrace' follows non-static declaration
[cysignals-1.6.0]     In file included from build/src/cysignals/signals.c:460:0:
[cysignals-1.6.0]     build/src/cysignals/macros.h:243:9: note: previous implicit declaration of 'print_backtrace' was here
[cysignals-1.6.0]              print_backtrace();
[cysignals-1.6.0]              ^~~~~~~~~~~~~~~
[cysignals-1.6.0]     error: command 'gcc' failed with exit status 1
[cysignals-1.6.0]     Running setup.py install for cysignals: finished with status 'error'

comment:17 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:18 Changed 5 years ago by git

  • Commit changed from 3f0fc375ae85557c68d8b88674eaf68bf8b11f75 to 8c059574a67f401635ebc4a5708e8bf56ae2c3e5

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

f2bcabdUpgrade to cysignals version 1.6.3
8c05957Fix doctest for cysignals upgrade

comment:19 Changed 5 years ago by jdemeyer

  • Status changed from needs_work to needs_review

Fixed in 1.6.3

comment:20 Changed 5 years ago by vbraun

The tests don't work:

[cysignals-1.6.3] creating build/temp.macosx-10.9-x86_64-2.7
[cysignals-1.6.3] gcc -fno-strict-aliasing -I/Users/buildslave-sage/slave/sage_git/build/local/var/tmp/sage/build/python2-2.7.13.p0/include -DNDEBUG -g -fwrapv -O3 -Wall -Wno-unused -I/Users/buildslave-sage/slave/sage_git/build/local/var/tmp/sage/build/cysignals-1.6.3/src/tmp/user/lib/python2.7/site-packages/cysignals -I/Users/buildslave-sage/slave/sage_git/build/local/include/python2.7 -c cysignals_example.cpp -o build/temp.macosx-10.9-x86_64-2.7/cysignals_example.o
[cysignals-1.6.3] cysignals_example.cpp:470:28: fatal error: struct_signals.h: No such file or directory
[cysignals-1.6.3] compilation terminated.
[cysignals-1.6.3] error: command 'gcc' failed with exit status 1
[cysignals-1.6.3] make[3]: *** [check-prefix-example] Error 1
[cysignals-1.6.3] src/cysignals/pselect.pyx
[cysignals-1.6.3] src/cysignals/pysignals.pyx
[cysignals-1.6.3] src/cysignals/signals.pyx
[cysignals-1.6.3] src/cysignals/tests.pyx
[cysignals-1.6.3] make[3]: Target `check' not remade because of errors.
[cysignals-1.6.3] 
[cysignals-1.6.3] real	0m35.818s
[cysignals-1.6.3] user	0m29.127s
[cysignals-1.6.3] sys	0m0.960s
[cysignals-1.6.3] ************************************************************************
[cysignals-1.6.3] Error testing package cysignals-1.6.3
[cysignals-1.6.3] ************************************************************************

comment:21 Changed 5 years ago by jdemeyer

I cannot reproduce that on Linux. Are you using some unusual compiler or environment variables?

I'll test it on your OSX machine now.

comment:22 Changed 5 years ago by jdemeyer

Got it. It's a race condition with parallel builds.

Thanks for the report.

comment:23 Changed 5 years ago by jdemeyer

  • Status changed from needs_review to needs_work

comment:24 Changed 5 years ago by git

  • Commit changed from 8c059574a67f401635ebc4a5708e8bf56ae2c3e5 to f11f773689833978ba9d964f5d4de9e295012555

Branch pushed to git repo; I updated commit sha1. New commits:

f11f773Run "check-install" (to check installed version of cysignals)

comment:25 Changed 5 years ago by jdemeyer

  • Status changed from needs_work to needs_review

Fixed in two ways:

  1. Instead of doing make check (which does a temporary installation), we run make check-install in Sage, which checks the installed version of cysignals.
  1. The race condition with make check is fixed upstream.

comment:26 Changed 5 years ago by vbraun

  • Branch changed from u/jdemeyer/upgrade_cysignals to f11f773689833978ba9d964f5d4de9e295012555
  • Resolution set to fixed
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.