Opened 4 years ago

Closed 4 years ago

#22551 closed enhancement (fixed)

Deprecate the old .field() method from polyhedron class

Reported by: jipilab Owned by:
Priority: major Milestone: sage-7.6
Component: geometry Keywords: days84, geometry
Cc: moritz, mkoeppe, vdelecroix, tmonteil, chapoton Merged in:
Authors: Jean-Philippe Labbé Reviewers: Vincent Delecroix
Report Upstream: N/A Work issues:
Branch: 6291dd1 (Commits, GitHub, GitLab) Commit: 6291dd1806a919cb9a83c4863b0c130c044742dd
Dependencies: Stopgaps:

Status badges

Description

Ticket #11634 made the ppl library be the default backend for the Polyhedron class.

Currently, Polyhedron objects still have a .field() method which is ill-named and since #11634 out-dated.

This ticket deprecates this method.

Change History (12)

comment:1 Changed 4 years ago by jipilab

  • Branch set to u/jipilab/deprecate_field

comment:2 Changed 4 years ago by jipilab

  • Commit set to 1e26fe924672a8d4e2fcfc4c94326d49d086f2cd
  • Status changed from new to needs_review

New commits:

1e26fe9Deprecate old keyword and method field

comment:3 follow-up: Changed 4 years ago by vdelecroix

  • Branch u/jipilab/deprecate_field deleted
  • Commit 1e26fe924672a8d4e2fcfc4c94326d49d086f2cd deleted

In cdd_convert you need to test the deprecation

comment:4 Changed 4 years ago by vdelecroix

  • Branch set to u/jipilab/deprecate_field
  • Commit set to 1e26fe924672a8d4e2fcfc4c94326d49d086f2cd

New commits:

1e26fe9Deprecate old keyword and method field

comment:5 follow-up: Changed 4 years ago by vdelecroix

@@ -2032,8 +2032,6 @@ class Polyhedron_base(Element):
         """
         return self.parent().base_ring()
 
-    field = base_ring
-
     @cached_method
     def center(self):

No deprecation here?

comment:6 Changed 4 years ago by vdelecroix

  • Reviewers set to Vincent Delecroix
  • Status changed from needs_review to needs_info

comment:7 in reply to: ↑ 5 Changed 4 years ago by jipilab

Replying to vdelecroix:

@@ -2032,8 +2032,6 @@ class Polyhedron_base(Element):
         """
         return self.parent().base_ring()
 
-    field = base_ring
-
     @cached_method
     def center(self):

No deprecation here?

Hmm. Right. I confused the keyword with the method here. I will add a deprecation warning.

comment:8 in reply to: ↑ 3 Changed 4 years ago by jipilab

Replying to vdelecroix:

In cdd_convert you need to test the deprecation

Since it is in a nested function, I removed the deprecation warning.

This was intended merely to make the nomenclature about base ring consistent across the geometry component...

comment:9 Changed 4 years ago by git

  • Commit changed from 1e26fe924672a8d4e2fcfc4c94326d49d086f2cd to 6291dd1806a919cb9a83c4863b0c130c044742dd

Branch pushed to git repo; I updated commit sha1. New commits:

6291dd1Added and removed deprecation warnings

comment:10 Changed 4 years ago by jipilab

  • Status changed from needs_info to needs_review

comment:11 Changed 4 years ago by vdelecroix

  • Status changed from needs_review to positive_review

I can not reproduce the timeout from the patchbot.

comment:12 Changed 4 years ago by vbraun

  • Branch changed from u/jipilab/deprecate_field to 6291dd1806a919cb9a83c4863b0c130c044742dd
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.