Opened 13 years ago

Closed 13 years ago

#2255 closed defect (duplicate)

matrix transpose does not maintain subdivision information

Reported by: ncalexan Owned by: was
Priority: minor Milestone: sage-2.10.3
Component: linear algebra Keywords: matrix transpose subdivision subdivide
Cc: ncalexander@… Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: tau = CC(I)*matrix(2, 2, [2, 0, 0, 2])
sage: B = block_matrix([tau, tau, tau, tau], 2, 2)
sage: B

[2.00000000000000*I                  0|2.00000000000000*I                  0]
[                 0 2.00000000000000*I|                 0 2.00000000000000*I]
[-------------------------------------+-------------------------------------]
[2.00000000000000*I                  0|2.00000000000000*I                  0]
[                 0 2.00000000000000*I|                 0 2.00000000000000*I]
sage: B.transpose()

[2.00000000000000*I                  0 2.00000000000000*I                  0]
[                 0 2.00000000000000*I                  0 2.00000000000000*I]
[2.00000000000000*I                  0 2.00000000000000*I                  0]
[                 0 2.00000000000000*I                  0 2.00000000000000*I]

Change History (1)

comment:1 Changed 13 years ago by ncalexan

  • Resolution set to duplicate
  • Status changed from new to closed

This is essentially a duplicate of #2142.

Note: See TracTickets for help on using tickets.