Opened 3 years ago

Closed 3 years ago

#22537 closed enhancement (fixed)

Use Python 3 metaclass syntax in Cython code

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-7.6
Component: python3 Keywords:
Cc: chapoton Merged in:
Authors: Jeroen Demeyer Reviewers: Frédéric Chapoton
Report Upstream: N/A Work issues:
Branch: ba82671 (Commits) Commit: ba82671db9807e151a7ae5f72fe76c4456ab4c05
Dependencies: Stopgaps:

Description


Change History (9)

comment:1 Changed 3 years ago by jdemeyer

  • Summary changed from Use Python 3 metaclass syntax in Cython files to Use Python 3 metaclass syntax in Cython code

comment:2 Changed 3 years ago by jdemeyer

  • Branch set to u/jdemeyer/use_python_3_metaclass_syntax_in_cython_files

comment:3 Changed 3 years ago by jdemeyer

  • Commit set to ba82671db9807e151a7ae5f72fe76c4456ab4c05
  • Status changed from new to needs_review

New commits:

ba82671Use Python 3 metaclass syntax

comment:4 follow-up: Changed 3 years ago by chapoton

This seems to break things quite badly.. at least the patchbot shows a rather strange result..

comment:5 in reply to: ↑ 4 Changed 3 years ago by jdemeyer

Replying to chapoton:

This seems to break things quite badly.. at least the patchbot shows a rather strange result..

I don't know what you are seeing. I see just one timeout in src/sage/doctest/test.py

comment:6 follow-up: Changed 3 years ago by chapoton

well, my patchbot shortlog contains (among many other bad-looking things)

Attaching gdb to process id 45443.

Saved trace to /home/u1/chapoton/.sage/crash_logs/crash_TkiqJY.log
------------------------------------------------------------------------
Unhandled SIGABRT: An abort() occurred.
This probably occurred because a *compiled* module has a bug
in it and is not properly wrapped with sig_on(), sig_off().
Python will now terminate.

comment:7 in reply to: ↑ 6 Changed 3 years ago by jdemeyer

Replying to chapoton:

well, my patchbot shortlog contains (among many other bad-looking things)

It seems that your patchbot is the only one, so then this ticket probably is not the cause.

comment:8 Changed 3 years ago by chapoton

  • Reviewers set to Frédéric Chapoton
  • Status changed from needs_review to positive_review

ok, last run of the patchbot is green and changes look good to me

setting to positive

comment:9 Changed 3 years ago by vbraun

  • Branch changed from u/jdemeyer/use_python_3_metaclass_syntax_in_cython_files to ba82671db9807e151a7ae5f72fe76c4456ab4c05
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.