Opened 4 years ago

Closed 4 years ago

#22496 closed enhancement (fixed)

Improve and fix documentation of Combinatorial or Discrete Geometry

Reported by: jipilab Owned by:
Priority: major Milestone: sage-7.6
Component: geometry Keywords: doc, polyhedron, geometry, days84
Cc: moritz, mkoeppe, vdelecroix, tmonteil, chapoton Merged in:
Authors: Jean-Philippe Labbé Reviewers: Vincent Klein
Report Upstream: N/A Work issues:
Branch: f931571 (Commits, GitHub, GitLab) Commit: f931571b273b1957634be1d4b98908df6dd88197
Dependencies: Stopgaps:

Status badges

Description (last modified by jipilab)

The reference manual for the currently called combinatorial geometry needs some logical reorganization.

http://doc.sagemath.org/html/en/reference/geometry/index.html

This ticket fixes the following:

  • add the normaliz backend to the references and add a note on how to install it.
  • fixes an indentation that caused the documentation not to build in the normaliz backend
  • the section on combinatorial geometry is renamed by adding also Discrete
  • the section on hyperbolic geometry gets moved in the table of content to Geometry and Topology and not inside Combinatorial and Discrete Geometry (which made no sense).
  • the combinatorial and discrete geometry table of content is restructured logically.
  • fixes a small bug in the documentation of the base class of polyhedron (missing backtick)
  • added some links to other modules in the constructor of polyhedra to different classes and backends.

Change History (25)

comment:1 Changed 4 years ago by jipilab

  • Branch set to u/jipilab/improve_doc_poly

comment:2 Changed 4 years ago by git

  • Commit set to e6beae2ab804628a3004063203c43fe867864649

Branch pushed to git repo; I updated commit sha1. New commits:

e6beae2Corrected a title

comment:3 Changed 4 years ago by jipilab

  • Type changed from PLEASE CHANGE to enhancement

comment:4 Changed 4 years ago by jipilab

  • Cc chapoton added

comment:5 Changed 4 years ago by chapoton

Salut !

missing empty line here

+.. NOTE::
+    This backend requires `PyNormaliz <https://pypi.python.org/pypi/PyNormaliz/1.5>`_.

and in several other places....

comment:6 Changed 4 years ago by git

  • Commit changed from e6beae2ab804628a3004063203c43fe867864649 to 38a89ebcb63d09a8b2e00e801d9360d138c42baf

Branch pushed to git repo; I updated commit sha1. New commits:

38a89ebAdded missing linespacing

comment:7 Changed 4 years ago by git

  • Commit changed from 38a89ebcb63d09a8b2e00e801d9360d138c42baf to 71b1f420886b5f615604810e83da7e11ffec575a

Branch pushed to git repo; I updated commit sha1. New commits:

71b1f42Several small corrections

comment:8 Changed 4 years ago by jipilab

  • Description modified (diff)
  • Status changed from new to needs_review

comment:9 Changed 4 years ago by git

  • Commit changed from 71b1f420886b5f615604810e83da7e11ffec575a to 1a1e7b15735e4b69de2c91e18420b57fa66fba0d

Branch pushed to git repo; I updated commit sha1. New commits:

1a1e7b1Corrected the indentation of an input block

comment:10 follow-up: Changed 4 years ago by novoselt

I would not give cones and fan "Toric Varieties" title, there are classes for these which are based on fans and cones. Also lattice_polytope logically fits with them better.

comment:11 in reply to: ↑ 10 Changed 4 years ago by jipilab

I would not give cones and fan "Toric Varieties" title, there are classes for these which are based on fans and cones.

I agree. I was sorting through the files and for the first version I put the 7 files whose documentation started with

This module was designed as a part of framework for toric varieties

together in a section called Toric Varieties.

Perhaps naming the section. Lattices, Cones, Fans, and related objects ? What do you think? Do you have any suggestions?

Also lattice_polytope logically fits with them better.

Okay. Are there other modules that would logically go with them as well?

comment:12 follow-up: Changed 4 years ago by novoselt

"Toric Geometry" may be appropriate, just no "varieties" themselves, I think.

Everything under "Lattice polyhedra" may be clamped with it - while there are presumably other reasons to consider them, almost everything here was done with toric geometry and mirror symmetry applications in mind.

comment:13 in reply to: ↑ 12 Changed 4 years ago by jipilab

Replying to novoselt:

"Toric Geometry" may be appropriate, just no "varieties" themselves, I think.

Sounds good.

Everything under "Lattice polyhedra" may be clamped with it - while there are presumably other reasons to consider them, almost everything here was done with toric geometry and mirror symmetry applications in mind.

I could put it in the polyhedral computations section after the lattice polytopes, that would be good? One argument to keep "Toric geometry" in its own section is somehow to reflect a little bit the structure in the geometry component (although I admit it does not necessarily have to follow it...) since polyhedron is a module on its own and the toric geometry framework is located directly in geometry and not in polyhedron...

I'm fine with both.

comment:14 Changed 4 years ago by git

  • Commit changed from 1a1e7b15735e4b69de2c91e18420b57fa66fba0d to 51a05cf09ad151dd77eb37a9e088ea9b73efd60d

Branch pushed to git repo; I updated commit sha1. New commits:

51a05cfRenamed subsection and moved it

comment:15 Changed 4 years ago by jipilab

  • Dependencies set to #22469

comment:16 follow-up: Changed 4 years ago by tmonteil

  • Dependencies #22469 deleted

A very related question (for another ticket, but it is good to have your opinion while you are at it) would be to move the isolated python files within src/sage/geometry/ into some appropriate directory, like riemannian_manifolds for riemannian manifolds, polyhedron for polyhedra, etc.

The files to classify are:

  • cone.py
  • fan_isomorphism.py
  • fan_morphism.py
  • fan.py
  • hasse_diagram.py
  • integral_points.pyx
  • lattice_polytope.py
  • linear_expression.py
  • newton_polygon.py
  • point_collection.pyx
  • pseudolines.py
  • ribbon_graph.py
  • toric_lattice_element.pyx
  • toric_lattice.py
  • toric_plotter.py

comment:17 in reply to: ↑ 16 ; follow-up: Changed 4 years ago by novoselt

Would make sense to have src/sage/geometry/toric similar to src/sage/schemes/toric with files

  • cone.py
  • fan_isomorphism.py
  • fan_morphism.py
  • fan.py
  • lattice_polytope.py
  • point_collection.pyx
  • toric_lattice_element.pyx
  • toric_lattice.py
  • toric_plotter.py

comment:18 in reply to: ↑ 17 Changed 4 years ago by tmonteil

Replying to novoselt:

Would make sense to have src/sage/geometry/toric similar to src/sage/schemes/toric with files

  • cone.py
  • fan_isomorphism.py
  • fan_morphism.py
  • fan.py
  • lattice_polytope.py
  • point_collection.pyx
  • toric_lattice_element.pyx
  • toric_lattice.py
  • toric_plotter.py

OK great, having such a src/sage/geometry/toric would be a good step toward cleaning up src/sage/geometry !

comment:19 Changed 4 years ago by git

  • Commit changed from 51a05cf09ad151dd77eb37a9e088ea9b73efd60d to 27f9f4dbd3073639df9addc26ec0f8dddf10b67f

Branch pushed to git repo; I updated commit sha1. New commits:

27f9f4dRebased on 7.6.beta6

comment:20 Changed 4 years ago by jipilab

  • Dependencies set to #13517

Okay. I would say that it is ready to be reviewed again.

comment:21 Changed 4 years ago by jipilab

  • Dependencies #13517 deleted

comment:22 Changed 4 years ago by git

  • Commit changed from 27f9f4dbd3073639df9addc26ec0f8dddf10b67f to f931571b273b1957634be1d4b98908df6dd88197

Branch pushed to git repo; I updated commit sha1. New commits:

f931571Corrected indentation in doc

comment:23 Changed 4 years ago by vklein

  • Reviewers set to Vincent Klein

comment:24 Changed 4 years ago by vklein

  • Status changed from needs_review to positive_review

doctest passed on :

  • src/sage/geometry/polyhedron/backend_normaliz.py
  • src/sage/geometry/polyhedron/base.py
  • src/sage/geometry/polyhedron/constructor.py

build of the doc passed and page discrete_geometry/index.html looks conform.

comment:25 Changed 4 years ago by vbraun

  • Branch changed from u/jipilab/improve_doc_poly to f931571b273b1957634be1d4b98908df6dd88197
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.