Opened 4 years ago

Closed 4 years ago

#22483 closed defect (duplicate)

Non-deterministic test failure in sage.libs.gap

Reported by: embray Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: interfaces Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Similar to #22482, another semi-random test failure I get when running sage -t -a -p 0 in the develop Docker container (off a current version of the develop branch) is:

sage -t /opt/sage/src/sage/libs/gap/all_documented_functions.py
    [4 tests, 105.48 s]
sage -t /opt/sage/src/sage/libs/gap/assigned_names.py
**********************************************************************
File "/opt/sage/src/sage/libs/gap/assigned_names.py", line 59, in sage.libs.gap.assigned_names.load_or_compute
Failed example:
    workspace(name='globals')
Expected:
    ('...', True)
Got:
    ('/home/sage/.sage/gap/libgap-globals-5920393023770190458', False)
**********************************************************************
1 item had failures:
   1 of   5 in sage.libs.gap.assigned_names.load_or_compute
    [15 tests, 1 failure, 105.33 s]

This one usually happens the first time I run the tests after a fresh build, but never subsequently. It doesn't seem to always happen though.

Change History (1)

comment:1 Changed 4 years ago by jdemeyer

  • Milestone changed from sage-7.6 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to closed

Duplicate of #20421.

Note: See TracTickets for help on using tickets.