Opened 5 years ago

Closed 5 years ago

#22421 closed defect (fixed)

Pynac's to_gamma() is buggy

Reported by: jdemeyer Owned by:
Priority: blocker Milestone: sage-7.6
Component: packages: standard Keywords:
Cc: rws Merged in:
Authors: Ralf Stephan Reviewers: Jeroen Demeyer
Report Upstream: Fixed upstream, but not in a stable release. Work issues:
Branch: 0a73359 (Commits, GitHub, GitLab) Commit: 0a733596fab3a285fbded6a02f9e65050a7cc306
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

See https://github.com/pynac/pynac/issues/231

On some systems (possibly depending on the linker), this doctest fails:

sage -t src/sage/symbolic/expression.pyx
**********************************************************************
File "src/sage/symbolic/expression.pyx", line 9627, in sage.symbolic.expression.Expression.to_gamma
Failed example:
    binomial(m,n).to_gamma()
Expected:
    gamma(m + 1)/(gamma(m - n + 1)*gamma(n + 1))
Got:
    binomial(m, n)
**********************************************************************

Change History (11)

comment:1 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:2 follow-up: Changed 5 years ago by jdemeyer

Do you have an idea how much time you need to fix the problems with #22364? Given that #22364 needs work anyway, it makes sense to fix this ticket there (and close this as duplicate). On the other hand, if you don't manage to fix #22364 quickly, we should fix this ticket first because it gives doctest failures.

comment:3 Changed 5 years ago by jdemeyer

  • Report Upstream changed from Reported upstream. No feedback yet. to Fixed upstream, but not in a stable release.

comment:4 in reply to: ↑ 2 Changed 5 years ago by rws

Replying to jdemeyer:

Do you have an idea how much time you need to fix the problems with #22364? Given that #22364 needs work anyway, it makes sense to fix this ticket there (and close this as duplicate). On the other hand, if you don't manage to fix #22364 quickly, we should fix this ticket first because it gives doctest failures.

No idea about the time because the cause of that is not established with certainty. So, as fixing this the usual way would need a new release that includes #22364 it would be best to not do a release but commit a Pynac patch (containing https://github.com/pynac/pynac/commit/a4dce19f33fc52245f324cb535d24233988dcfa1.diff) with this branch.

comment:5 Changed 5 years ago by rws

  • Branch set to u/rws/pynac_s_to_gamma___is_buggy

comment:6 Changed 5 years ago by rws

  • Authors set to Ralf Stephan
  • Commit set to 7cdbdb0144be8c9fb413b1c33571598c5c43562c
  • Status changed from new to needs_review

New commits:

7cdbdb022421: apply commit from (future) Pynac master

comment:7 Changed 5 years ago by jdemeyer

  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_review to needs_work

Patches are automatically applied now, you should not manually run sage-apply-patches (so you can remove the whole patch() function).

comment:8 Changed 5 years ago by git

  • Commit changed from 7cdbdb0144be8c9fb413b1c33571598c5c43562c to 0a733596fab3a285fbded6a02f9e65050a7cc306

Branch pushed to git repo; I updated commit sha1. New commits:

0a7335922421: clean up spkg-install

comment:9 Changed 5 years ago by rws

  • Status changed from needs_work to needs_review

comment:10 Changed 5 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:11 Changed 5 years ago by vbraun

  • Branch changed from u/rws/pynac_s_to_gamma___is_buggy to 0a733596fab3a285fbded6a02f9e65050a7cc306
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.