Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#22364 closed enhancement (fixed)

Upgrade to pynac-0.7.5

Reported by: rws Owned by:
Priority: major Milestone: sage-7.6
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Ralf Stephan Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: 8d7801e (Commits) Commit:
Dependencies: #22421 Stopgaps:

Description (last modified by rws)

Pynac-0.7.5 has

  • crucial improvements to Gosper algorithm (#22090)
  • pynac.pc additions

https://github.com/pynac/pynac/releases/download/pynac-0.7.5/pynac-0.7.5.tar.bz2

Change History (23)

comment:1 Changed 2 years ago by rws

  • Branch set to u/rws/upgrade_to_pynac_0_7_5

comment:2 Changed 2 years ago by rws

  • Branch u/rws/upgrade_to_pynac_0_7_5 deleted
  • Description modified (diff)
  • Status changed from new to needs_review

comment:3 Changed 2 years ago by rws

  • Authors set to Ralf Stephan

comment:4 Changed 2 years ago by rws

  • Branch set to u/rws/upgrade_to_pynac_0_7_5
  • Commit set to 46697e020a94c9ddb9375dcf92597dd5830f8201

New commits:

46697e0pkg version/chksum

comment:5 Changed 2 years ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

comment:6 Changed 2 years ago by vbraun

  • Status changed from positive_review to needs_work
sage -t --long --warn-long 79.1 src/sage/functions/orthogonal_polys.py
**********************************************************************
File "src/sage/functions/orthogonal_polys.py", line 1884, in sage.functions.orthogonal_polys.Func_jacobi_P._eval_
Failed example:
    jacobi_P(1,n,n,n)
Expected:
    (n + 1)*n
Got:
    (n + 1)*((n - 1)*gamma(2*n + 2)/gamma(n + 1) + gamma(2*n + 2)/gamma(n + 1))*gamma(n + 1)/gamma(2*n + 2)
**********************************************************************
File "src/sage/functions/orthogonal_polys.py", line 1888, in sage.functions.orthogonal_polys.Func_jacobi_P._eval_
Failed example:
    jacobi_P(1,n,n,x)
Expected:
    (n + 1)*x
Got:
    (n + 1)*((x - 1)*gamma(2*n + 2)/gamma(n + 1) + gamma(2*n + 2)/gamma(n + 1))*gamma(n + 1)/gamma(2*n + 2)
**********************************************************************
1 item had failures:
   2 of  13 in sage.functions.orthogonal_polys.Func_jacobi_P._eval_
    [378 tests, 2 failures, 7.87 s]
----------------------------------------------------------------------
sage -t --long --warn-long 79.1 src/sage/functions/orthogonal_polys.py  # 2 doctests failed
----------------------------------------------------------------------
Total time for all tests: 8.1 seconds
    cpu time: 5.3 seconds
    cumulative wall time: 7.9 seconds

comment:7 Changed 2 years ago by git

  • Commit changed from 46697e020a94c9ddb9375dcf92597dd5830f8201 to 32809571474d35f1dda99986d68dde7c1302b5e8

Branch pushed to git repo; I updated commit sha1. New commits:

20f0b48Merge branch 'develop' into t/22364/upgrade_to_pynac_0_7_5
328095722364: add normalization step to jacobi_P.eval

comment:8 Changed 2 years ago by rws

  • Status changed from needs_work to needs_review

comment:9 Changed 2 years ago by vbraun

  • Status changed from needs_review to positive_review

comment:10 Changed 2 years ago by vbraun

I'm getting this on 32-bit

sage -t --long src/sage/functions/orthogonal_polys.py
**********************************************************************
File "src/sage/functions/orthogonal_polys.py", line 1886, in sage.functions.orthogonal_polys.Func_jacobi_P._eval_
Failed example:
    jacobi_P(2,n,n,n)
Expected:
    1/4*(2*n - 1)*(n + 2)*(n + 1)^2
Got:
    1/4*(2*n^2 + n - 1)*(n + 2)*(n + 1)
**********************************************************************
1 item had failures:
   1 of  13 in sage.functions.orthogonal_polys.Func_jacobi_P._eval_
    [378 tests, 1 failure, 8.03 s]

comment:11 Changed 2 years ago by vbraun

There are some more, possibly related to #22057

sage -t --long src/sage/symbolic/expression.pyx
**********************************************************************
File "src/sage/symbolic/expression.pyx", line 6729, in sage.symbolic.expression.Expression.resultant
Failed example:
    (x+y).resultant(x-y, x)
Expected:
    -2*y
Got:
    2*x
**********************************************************************
File "src/sage/symbolic/expression.pyx", line 6732, in sage.symbolic.expression.Expression.resultant
Failed example:
    r.coefficient(a^4)
Expected:
    b^4*y^2 - 4*b^3*y^3 + 6*b^2*y^4 - 4*b*y^5 + y^6
Got:
    0
**********************************************************************
1 item had failures:
   2 of   7 in sage.symbolic.expression.Expression.resultant
    [2670 tests, 2 failures, 35.16 s]

comment:12 Changed 2 years ago by vbraun

  • Status changed from positive_review to needs_work

comment:13 Changed 2 years ago by rws

What's the easiest way to build a 32bit Sage for debugging this? Volker, can you give me an account?

comment:14 Changed 2 years ago by rws

Hold on, I confirm there is a problem with resultants when I merge #22057 into this.,

comment:15 Changed 2 years ago by rws

As there were 32bit problems with Giac I think it would be safer if we used Singular on 32bit instead. Fortunately I provided for such build-time switching. Now this should just be a matter of spkg-install...

comment:16 Changed 2 years ago by jdemeyer

  • Dependencies set to #22421

comment:17 Changed 2 years ago by rws

On the other hand failure on 32 bit indicates underlying bugs so, sadly, I'll switch off Giac support again until #22101 and #22280 have been sorted out and then try again. If the 32 bit problems persist then at least we know it's not Giac in this case.

comment:18 Changed 2 years ago by git

  • Commit changed from 32809571474d35f1dda99986d68dde7c1302b5e8 to 8d7801ec16d3376adc414f241e94bbd4a5af1fb3

Branch pushed to git repo; I updated commit sha1. New commits:

7cdbdb022421: apply commit from (future) Pynac master
0a7335922421: clean up spkg-install
58f10d5Merge branch 'u/rws/pynac_s_to_gamma___is_buggy' of git://trac.sagemath.org/sage into t/22364/upgrade_to_pynac_0_7_5
8d7801e22364: turn off Giac usage of Pynac

comment:19 Changed 2 years ago by rws

  • Status changed from needs_work to needs_review

comment:20 Changed 2 years ago by vbraun

  • Status changed from needs_review to positive_review

comment:21 Changed 2 years ago by vbraun

  • Branch changed from u/rws/upgrade_to_pynac_0_7_5 to 8d7801ec16d3376adc414f241e94bbd4a5af1fb3
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:22 follow-up: Changed 2 years ago by fbissey

  • Commit 8d7801ec16d3376adc414f241e94bbd4a5af1fb3 deleted

Something weird is happening to me here in sage-on-gentoo. Tests were OK after merging of this and #22057. Now that we have moved past 7.6.beta6 (I work off Volker's tree usually) I have the failures in symbolic/expression.pyx and functions/orthogonal_polys.py again. For the later it is even stranger, I get the failure only the first time I run the test, subsequent testing of functions/orthogonal_polys.py pass but not symbolic/expression.pyx.

Could it be caused by ginac, since I still have it enabled in pynac? But why would it re-appear after 7.6.beta6 has been released?

comment:23 in reply to: ↑ 22 Changed 2 years ago by rws

Replying to fbissey:

Could it be caused by ginac, since I still have it enabled in pynac? But why would it re-appear after 7.6.beta6 has been released?

Giac? Yes that's why I disabled it again (comment:17). On the other hand if the problems persist even when you disable it too, then please open a ticket because that would be unexpected.

Note: See TracTickets for help on using tickets.