Opened 6 years ago

Last modified 6 years ago

#22252 closed enhancement

Upgrade to Sphinx 1.5.x — at Version 7

Reported by: Jeroen Demeyer Owned by:
Priority: major Milestone: sage-7.6
Component: packages: standard Keywords: days85
Cc: François Bissey Merged in:
Authors: Jeroen Demeyer Reviewers:
Report Upstream: Fixed upstream, but not in a stable release. Work issues:
Branch: u/jdemeyer/upgrade_to_sphinx_1_5_2 (Commits, GitHub, GitLab) Commit: 6a61a49ecfede1b9648a30361fa90df52e94fb15
Dependencies: Stopgaps:

Status badges

Change History (7)

comment:1 Changed 6 years ago by François Bissey

Should we update docutils to 0.13 at the same time? sphinx 1.5.2 as all the fix to work with it as far as I know, can be in a separate ticket but it is better if they are done at the same time given the comments in https://github.com/cschwan/sage-on-gentoo/issues/451

comment:2 Changed 6 years ago by Jeroen Demeyer

I would say: let's do whatever is easiest. So the question is: is it easier to make Sage and Sphinx-1.5.2 work with docutils-0.12 or with docutils-0.13?

comment:3 Changed 6 years ago by François Bissey

Thinking more about it, sphinx 1.5.2 should work with both, so we can do sphinx first then docutils afterwards.

comment:4 Changed 6 years ago by Jeroen Demeyer

Description: modified (diff)

comment:5 Changed 6 years ago by Jeroen Demeyer

Branch: u/jdemeyer/upgrade_to_sphinx_1_5_2

comment:6 Changed 6 years ago by git

Commit: 6a61a49ecfede1b9648a30361fa90df52e94fb15

Branch pushed to git repo; I updated commit sha1. New commits:

6a61a49Doc fixes for Sphinx-1.5

comment:7 Changed 6 years ago by Jeroen Demeyer

Authors: Jeroen Demeyer
Description: modified (diff)
Summary: Upgrade to Sphinx 1.5.2Upgrade to Sphinx 1.5.x
Note: See TracTickets for help on using tickets.