Opened 6 years ago

Closed 6 years ago

#22222 closed enhancement (fixed)

Remove _pari_instance global

Reported by: Jeroen Demeyer Owned by:
Priority: major Milestone: sage-7.6
Component: interfaces Keywords:
Cc: Luca De Feo, Vincent Delecroix Merged in:
Authors: Jeroen Demeyer Reviewers: Luca De Feo
Report Upstream: N/A Work issues:
Branch: 98869b4 (Commits, GitHub, GitLab) Commit: 98869b4f83de894281bf164016d7ef9a2f4b3227
Dependencies: Stopgaps:

Status badges

Description (last modified by Jeroen Demeyer)

The _pari_instance global in src/sage/libs/cypari2/pari_instance.pxd was introduced as temporary workaround. Ideally, it should not be needed.

Since many of the uses of pari_instance involve lists, I decided to create a new function cdef Gen list_of_Gens_to_Gen(list s) for fast conversion of a Python list of Gens to a Gen. This function is in turn called from objtogen.

Change History (14)

comment:1 Changed 6 years ago by Jeroen Demeyer

Authors: Jeroen Demeyer
Description: modified (diff)
Summary: Remove pari_instance global in gen.pyxRemove _pari_instance global

comment:2 Changed 6 years ago by Jeroen Demeyer

Dependencies: #22185

comment:3 Changed 6 years ago by Jeroen Demeyer

Description: modified (diff)

comment:4 Changed 6 years ago by Jeroen Demeyer

Dependencies: #22185#22185, #22210

comment:5 Changed 6 years ago by Jeroen Demeyer

Description: modified (diff)

comment:6 Changed 6 years ago by Jeroen Demeyer

Branch: u/jdemeyer/ticket/22222

comment:7 Changed 6 years ago by Jeroen Demeyer

Commit: 2d82cf9d7b9693d0c6125e6ce61502a40a641431
Status: newneeds_review

New commits:

de81adcTrac 22210: remove obsolete special case in PARI gen.eval()
7a35c89Merge commit '6022cab1880d6f3820e0f028671ddd2983eae42b'; commit 'ee54f071a26c63821f475d2832c7bb1fbbdd7e95' into ticket/22183
235efd3Rename PariInstance -> Pari
6f04abaRemove unused imports from sage
c258dcaRename gen -> Gen
0c4433cFix documentation
dbaf3b2Merge remote-tracking branch 'trac/u/jdemeyer/ticket/22185' into HEAD
2d82cf9Remove _pari_instance global

comment:8 Changed 6 years ago by Jeroen Demeyer

Status: needs_reviewneeds_work

comment:9 Changed 6 years ago by Jeroen Demeyer

Dependencies: #22185, #22210

comment:10 Changed 6 years ago by git

Commit: 2d82cf9d7b9693d0c6125e6ce61502a40a64143198869b4f83de894281bf164016d7ef9a2f4b3227

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

98869b4Remove _pari_instance global

comment:11 Changed 6 years ago by Jeroen Demeyer

Status: needs_workneeds_review

comment:12 Changed 6 years ago by Luca De Feo

Reviewers: Luca De Feo
Status: needs_reviewpositive_review

Good for me. I cannot reproduce the doctest timeout reported by patchbot.

Wondering about bernfrac, bernreal, and fibonacci. What is this L type in pari.desc?

comment:13 Changed 6 years ago by Jeroen Demeyer

L = C long

comment:14 Changed 6 years ago by Volker Braun

Branch: u/jdemeyer/ticket/2222298869b4f83de894281bf164016d7ef9a2f4b3227
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.