Opened 3 years ago

Closed 3 years ago

#22038 closed enhancement (duplicate)

Implement Zywina's algorithm

Reported by: cremona Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: PLEASE CHANGE Keywords:
Cc: wuthrich Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The current method for finding the set of nonsurjective primes for a non-CM elliptic curve over Q is based on Cojocaru's bounds. There is a more efficient algorithm by Zywina (see http://www.math.cornell.edu/~zywina/papers/EffectiveModl.pdf which contains the code in Magma -- very simple). This would be easy to implement to replace (or provide an alternative algorithm for) the function nonsurjective() in sage/schemes/elliptic_curves/gal_reps.py

Change History (2)

comment:1 Changed 3 years ago by wuthrich

This should be closed as a duplicate of #11270 .

I will add a comment there about the current state of this.

comment:2 Changed 3 years ago by jdemeyer

  • Milestone changed from sage-7.5 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.