Opened 4 years ago

Closed 4 years ago

#22012 closed enhancement (fixed)

Py3 : Handle cmp() in pyx files in misc and modules

Reported by: chapoton Owned by:
Priority: major Milestone: sage-7.5
Component: python3 Keywords:
Cc: tscrim, aapitzsch, jdemeyer Merged in:
Authors: Frédéric Chapoton Reviewers: André Apitzsch
Report Upstream: N/A Work issues:
Branch: 651fcfd (Commits) Commit: 651fcfd9f99633e1a532f23bede24717061d2d18
Dependencies: Stopgaps:

Description

as another step to python3

Change History (7)

comment:1 Changed 4 years ago by chapoton

  • Branch set to u/chapoton/22012
  • Cc tscrim aapitzsch jdemeyer added
  • Commit set to c841d8da75117d24f6bd6cc4e005c15cc50f5dfd
  • Status changed from new to needs_review

New commits:

c841d8dpy3 handling cmp() in two more pyx files

comment:2 Changed 4 years ago by git

  • Commit changed from c841d8da75117d24f6bd6cc4e005c15cc50f5dfd to 651fcfd9f99633e1a532f23bede24717061d2d18

Branch pushed to git repo; I updated commit sha1. New commits:

651fcfdtrac 22012 correct one failing doctest

comment:3 Changed 4 years ago by aapitzsch

LGTM.

Can you tell me why bool around w < v is needed in src/sage/modules/free_module_element.pyx?

comment:4 Changed 4 years ago by chapoton

It turns out that the changes made here do turn the comparison of elements of vecctors over the symbolic ring into "symbolic inequalities". Probably this should be the expected behaviour. But in some sense, this breaks the comparison of symbolic vectors (that should never have worked anyway, imho).

For me, SR is a rather awful and undefined thing, in which equality and comparison do not make sense. Maybe we will hit later a large scale problem when handling python3 conversion of cmp in SR, or maybe not.

comment:5 Changed 4 years ago by aapitzsch

  • Reviewers set to André Apitzsch

Okay.

If patchbot doesn't complain, you can set it to positive review.

comment:6 Changed 4 years ago by chapoton

  • Status changed from needs_review to positive_review

Thank you. Setting to positive.

comment:7 Changed 4 years ago by vbraun

  • Branch changed from u/chapoton/22012 to 651fcfd9f99633e1a532f23bede24717061d2d18
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.