Opened 13 years ago

Closed 13 years ago

#2197 closed defect (duplicate)

Elliptic Curve quadratic/quartic/sextic twists: unhelpful error message when D=0

Reported by: cremona Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebraic geometry Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The code for quadratic, quartic and sextic twists of elliptic curves does not check that the twisting parameter is nonzero, and hence fail when a singular curve tries to be constructed. Instead we output a helpful message.

Note that in characteristic 2, the quadratic twist by 0 is allowed (but gives back the same curve), just as twisting by 1 in odd characteristic.

The patch provided also enhances the Hasse_bounds function (which should probably be put somewhere other than ell_generic.py).

Change History (2)

comment:1 Changed 13 years ago by mabshoff

  • Milestone set to sage-2.10.2

comment:2 Changed 13 years ago by mabshoff

  • Milestone changed from sage-2.10.2 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #2196.

Note: See TracTickets for help on using tickets.