Opened 4 years ago

Closed 4 years ago

#21947 closed defect (fixed)

Don't let "tightpage" in view cut tikz images

Reported by: moritz Owned by:
Priority: minor Milestone: sage-7.5
Component: misc Keywords: days79, latex, tikz
Cc: nthiery, jipilab Merged in:
Authors: Moritz Firsching, Jeremias Epperlein Reviewers: Sébastien Labbé
Report Upstream: N/A Work issues:
Branch: f0a40b7 (Commits, GitHub, GitLab) Commit: f0a40b79e9f256b5734d545a922e5490fd028ea5
Dependencies: #21929 Stopgaps:

Status badges

Description

For certain images generated with tikz, using view with the default tightpage=True. (The feature was made default in #21929)

An example would be graphs:

G=graphs.PetersenGraph()
view(latex(G), tightpage=True)

Change History (13)

comment:1 Changed 4 years ago by moritz

  • Branch set to u/moritz/ticket/21947

comment:2 Changed 4 years ago by moritz

  • Commit set to 7ce0a0b2a1ca7bfad2ac1927ed7ed05a8f8ee96f

I propose to add an additional optin "border" to specify the size of the border and choose 5mm as a default for this.

comment:3 Changed 4 years ago by moritz

  • Status changed from new to needs_review

comment:4 Changed 4 years ago by jepperlein

  • Branch changed from u/moritz/ticket/21947 to u/jepperlein/ticket/21947

comment:5 Changed 4 years ago by git

  • Commit changed from 7ce0a0b2a1ca7bfad2ac1927ed7ed05a8f8ee96f to ab3eb43712abd1c87269a70094edc207a213f076

Branch pushed to git repo; I updated commit sha1. New commits:

ab3eb43Trac: #21947 Fix doctest in generic_graph

comment:6 Changed 4 years ago by git

  • Commit changed from ab3eb43712abd1c87269a70094edc207a213f076 to 5e70618e4520b4e79989a1ad71be499832795ec1

Branch pushed to git repo; I updated commit sha1. New commits:

5e70618Trac: #21947 Add possibility to not add a margin

comment:7 Changed 4 years ago by slabbe

  • Dependencies set to #21929

comment:8 Changed 4 years ago by slabbe

  • Authors set to Moritz Firsching, Jeremias Epperlein
  • Branch changed from u/jepperlein/ticket/21947 to u/slabbe/21947
  • Commit changed from 5e70618e4520b4e79989a1ad71be499832795ec1 to f0a40b79e9f256b5734d545a922e5490fd028ea5
  • Reviewers set to Sébastien Labbé

I added a small commit to follow the Python code style.


Last 10 new commits:

1bf4697removed some whitespace
7ce0a0ballowing to control the border of a view
46cae95Trac: #21947 Suppress title with tightpage
a65682bTrac: #21947 Rename border to margin, default to 0
e24d027Trac: #21947 Remove useasboundingbox, didn't work anyway
aeb236bTrac: #21947 Remove blank line after dot2tex picture
ab3eb43Trac: #21947 Fix doctest in generic_graph
5e70618Trac: #21947 Add possibility to not add a margin
e276c34Merge branch 'u/jepperlein/ticket/21947' of ssh://trac.sagemath.org/sage into 21947
f0a40b721947: no whitespace around = for keyword arguments

comment:9 follow-up: Changed 4 years ago by slabbe

Jeremias, can you add your username and name to the list in the "Wiki" home page of the Sage trac? This allows Sage to attribute your contribution properly.

comment:10 Changed 4 years ago by slabbe

I tested that documentation builds fine. The problem is fixed by the commits. Doctest pass in sage/misc/ and in sage/graphs. To me this is a positive review.

I let Jeremias or Moritz change the status to positive review since I added a small commit on top of theirs.

comment:11 in reply to: ↑ 9 Changed 4 years ago by jepperlein

I added my name to the Wiki page, hopefully at the intended place. I will put it to positive review now, last commit by slabbe looks fine.

comment:12 Changed 4 years ago by jepperlein

  • Status changed from needs_review to positive_review

comment:13 Changed 4 years ago by vbraun

  • Branch changed from u/slabbe/21947 to f0a40b79e9f256b5734d545a922e5490fd028ea5
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.