Opened 6 years ago

Closed 5 years ago

#21835 closed enhancement (duplicate)

Upgrade pip to 9.0.1

Reported by: Emmanuel Charpentier Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: pip
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: public/21835 (Commits, GitHub, GitLab) Commit: 3e304ef1f967952f7a06d14219dcbe9627bae9cf
Dependencies: Stopgaps:

Status badges

Description (last modified by Frédéric Chapoton)

the tar file for pip 9.0.1 is available here:

https://pypi.python.org/pypi/pip

Attachments (6)

pip8-patch-parallel-install.log.gz (1.5 MB) - added by Emmanuel Charpentier 6 years ago.
Failed parallel build log with pip 8 and #21812.
pip8-nopatch-ptestlong.log (367.7 KB) - added by Emmanuel Charpentier 6 years ago.
ptestlong log with pip 8 and no patch, exhibiting the problem created by pip advertising its new version.
pip8-patch-parallel-singular-4.0.3p3.log (120.5 KB) - added by Emmanuel Charpentier 6 years ago.
Log of failed Singular build with pip8, #21812 and parallel building
pip8-patch-serial-ptestlong.log.gz (40.7 KB) - added by Emmanuel Charpentier 6 years ago.
ptestlong log with pip 8 and #21812 exhibiting the desired result (no spurious doctest failures)
pip9-nopatch-ptestlong.log (368.0 KB) - added by Emmanuel Charpentier 6 years ago.
ptestlong log with pip 9 (manuallu upgraded), without #21812 : spurios doctest failures caused by "Deprecation" messages from pip.
pip9-patch-ptestlong.log (369.6 KB) - added by Emmanuel Charpentier 6 years ago.
ptestlong log obtained with pip9 (manually upgraded) and #21812, showing the spurious doctest failures due to "Deprecation" pip complaints not fixed by #21812.

Change History (20)

Changed 6 years ago by Emmanuel Charpentier

Failed parallel build log with pip 8 and #21812.

Changed 6 years ago by Emmanuel Charpentier

Attachment: pip8-nopatch-ptestlong.log added

ptestlong log with pip 8 and no patch, exhibiting the problem created by pip advertising its new version.

Changed 6 years ago by Emmanuel Charpentier

Log of failed Singular build with pip8, #21812 and parallel building

Changed 6 years ago by Emmanuel Charpentier

ptestlong log with pip 8 and #21812 exhibiting the desired result (no spurious doctest failures)

Changed 6 years ago by Emmanuel Charpentier

Attachment: pip9-nopatch-ptestlong.log added

ptestlong log with pip 9 (manuallu upgraded), without #21812 : spurios doctest failures caused by "Deprecation" messages from pip.

Changed 6 years ago by Emmanuel Charpentier

Attachment: pip9-patch-ptestlong.log added

ptestlong log obtained with pip9 (manually upgraded) and #21812, showing the spurious doctest failures due to "Deprecation" pip complaints not fixed by #21812.

comment:1 Changed 6 years ago by Emmanuel Charpentier

Note : All these trials were made with #21782, now necessary on my Debian system using gcc 6.2.0.

The logs show that :

  • without #21812, pip 8.x.y (our current version) advertising its new version creates spurious doctest failures.
  • with #21812, pip 8.x.x solves this problem. BUT
  • this log was obtained after a serial build of Sage ; a parallel build fails on Singular.
  • Manually upgrading pip to 9.0.0 causes different spurious doctest failures, by pip advertising a deprecation of its previous format.
  • These pip 9.0.0 deprecation warnings occur whether or not #21812 is installed.

I conclude that #21812

  • is only a temporary fix,
  • may be troublesome with some configurations.

comment:2 Changed 6 years ago by Dima Pasechnik

The first question is where Sage's pip is looking for its pip.conf. (to follow the warning to define a list_format in your pip.conf)

comment:3 Changed 6 years ago by Jeroen Demeyer

The file pip8-patch-parallel-install.log.gz shows a build failure with Singular. That is totally unrelated to pip. I believe that there is a problem with building Singular, but that failure has nothing to do with #21812.

comment:4 Changed 6 years ago by Tobias Hansen

The deprecation warnings can be gotten rid of by patching the same line as in #21812 and adding the option --format=legacy.

comment:5 Changed 6 years ago by Jeroen Demeyer

Description: modified (diff)
Type: defectenhancement

comment:6 Changed 6 years ago by Dima Pasechnik

was the description removed on purpose, or by oversight?

comment:7 in reply to:  6 ; Changed 6 years ago by Jeroen Demeyer

Replying to dimpase:

was the description removed on purpose, or by oversight?

On purpose since it was no longer relevant.

comment:8 in reply to:  4 Changed 6 years ago by Emmanuel Charpentier

Replying to thansen:

The deprecation warnings can be gotten rid of by patching the same line as in #21812 and adding the option --format=legacy.

I'm afraid that our current policy of "don't upgrade until absolutely necessary", while implementing a well-founded unease with novelty for novelty's sake, leads us to paint ourselves in unmaintainable corners.

In the present case, pip is now a cornerstone of python infrastructure. Trying to maintain its old format exposes us to the risk of more and more Sage-specific pip-related patches, aggravating its maintenance burden. While not as serious as the python2-python3 divergence, that, IMHO, we considered way too late, the analogy is here.

I'd consider what is currently a booboo as an incentive to *fix* the problem, not to work around it.

Of course, you can also consider that pip, used to add new packages, is not useful for "a majority" of Sage users. You will have as much trouble convincing me that you have tryng to convince me that SSL support can be optional (you didn't succeed yet).

Culd you please consider this bug as a serious warning about our future maintenance burden ?

comment:9 in reply to:  7 ; Changed 6 years ago by Emmanuel Charpentier

Replying to jdemeyer:

Replying to dimpase:

was the description removed on purpose, or by oversight?

On purpose since it was no longer relevant.

In my not so humble opinion, this description is *still* relevant. Removing it is a bit papering up a minor problem, leaving it time to become a major one...

I'd rather restore the original description (with your comments if you think necessary...).

comment:10 in reply to:  9 Changed 6 years ago by Jeroen Demeyer

Replying to charpent:

In my not so humble opinion, this description is *still* relevant. Removing it is a bit papering up a minor problem, leaving it time to become a major one...

The original description claimed that there were problems with #21812. That ticket is now merged without the claimed problem appearing. So that claim was simply wrong (as I already pointed out on sage-devel and in 3).

This has nothing to do with being in favour or against this ticket. I just don't want factually incorrect ticket descriptions.

Last edited 6 years ago by Jeroen Demeyer (previous) (diff)

comment:11 Changed 6 years ago by Frédéric Chapoton

Branch: public/21835
Commit: 3e304ef1f967952f7a06d14219dcbe9627bae9cf

New commits:

3e304efbranch for upgrading to pip 9.0.1

comment:12 Changed 6 years ago by Frédéric Chapoton

Description: modified (diff)
Milestone: sage-7.5sage-8.0
Summary: Upgrade pip to 9.0.0Upgrade pip to 9.0.1

comment:13 Changed 5 years ago by Jeroen Demeyer

Milestone: sage-8.0sage-duplicate/invalid/wontfix
Reviewers: Jeroen Demeyer
Status: newneeds_review

Duplicate of #23615.

comment:14 Changed 5 years ago by Jeroen Demeyer

Resolution: duplicate
Status: needs_reviewclosed
Note: See TracTickets for help on using tickets.