Opened 5 years ago

Closed 5 years ago

#21826 closed defect (duplicate)

Memory leak coming from Coin solver

Reported by: slabbe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: memleak Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Not yet reported upstream; Will do shortly. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

As reported on sage-devel by Saul Schleimer:

def get_polytope():
    q = MixedIntegerLinearProgram(maximization=False, solver='Coin')
    w = q.new_variable(real=True, nonnegative=True) 
    q.add_constraint(w[0]==0)

def fill_memory(n):
    for i in xrange(n):
        P = get_polytope()

sage: get_memory_usage()
288.58984375
sage: fill_memory(2000); get_memory_usage()
300.5859375
sage: fill_memory(2000); get_memory_usage()
302.5859375
sage: fill_memory(2000); get_memory_usage()
303.5859375
sage: fill_memory(2000); get_memory_usage()
305.5859375

Change History (3)

comment:1 Changed 5 years ago by slabbe

  • Milestone changed from sage-7.5 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Duplicate of #21825 which was open almost simultaneously by Dima.

comment:2 Changed 5 years ago by dimpase

  • Status changed from needs_review to positive_review

comment:3 Changed 5 years ago by embray

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.