Opened 4 years ago

Closed 3 years ago

#21796 closed enhancement (wontfix)

Clean up GAP installation, following Debian's layout

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: dimpase, fbissey, jdemeyer, vbraun Merged in:
Authors: Reviewers: Dima Pasechnik
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

As discussed on #15105, Debian splits the GAP installation into lib and share. We could do the same.

Change History (16)

comment:1 follow-up: Changed 4 years ago by jdemeyer

This should be done upstream and not just in Sage.

comment:2 in reply to: ↑ 1 ; follow-ups: Changed 4 years ago by dimpase

Replying to jdemeyer:

This should be done upstream and not just in Sage.

The problem here is that the upstream's milestone for this to happen is apparently "Ice age in Hell"...

comment:3 Changed 4 years ago by jdemeyer

If upstream doesn't care, why should Sage care? If you move away from upstream's install system, there should be a reason for that. And "just because Debian does it" is not sufficient reason IMHO.

comment:4 in reply to: ↑ 2 Changed 4 years ago by jdemeyer

  • Cc vbraun added

Replying to dimpase:

The problem here is that the upstream's milestone for this to happen is apparently "Ice age in Hell"...

Do you think they would accept a pull request to make the installation more sane?

comment:5 follow-ups: Changed 4 years ago by vbraun

Either before or after the heat death of the universe ;-)

Sanitizing the gap directory structure is likely to break some GAP third-party packages that expect said layout...

comment:6 in reply to: ↑ 5 Changed 4 years ago by jdemeyer

Replying to vbraun:

Sanitizing the gap directory structure is likely to break some GAP third-party packages that expect said layout...

Which is exactly why we should not have a different GAP directory structure compared to upstream.

comment:7 Changed 4 years ago by mkoeppe

OK, let's keep this ticket as an open wishlist item. We can wait until the next generation of GAP maintainers takes a fresh look.

comment:8 in reply to: ↑ 2 Changed 4 years ago by embray

Replying to dimpase:

Replying to jdemeyer:

This should be done upstream and not just in Sage.

The problem here is that the upstream's milestone for this to happen is apparently "Ice age in Hell"...

I'm curious what their reasoning is. What do they gain from having a non-standard installation?

comment:9 in reply to: ↑ 5 Changed 4 years ago by embray

Replying to vbraun:

Either before or after the heat death of the universe ;-)

Sanitizing the gap directory structure is likely to break some GAP third-party packages that expect said layout...

That seems like a problem for GAP + those packages then.

comment:10 Changed 4 years ago by fbissey

I looked at debian packages and they do have a collection of gap packages and yes some them are patched. I actually stole the patch for atlasrep and I even think sage should do too. It solve problems when sage is installed globally as root, including gap_packages which contains said atlasrep (which does fetch stuff from the internet and then wants to write them in GAP_ROOT_PATH/pkgs without the patch).

I do not follow debian scheme for gap in Gentoo at this stage. Upstream has developed over the years a nice self contained system with its own packaging. They probably never considered being packaged when they reached that state. Moving to a more standard installation scheme is now a cost against benefits problem. They'll be willing to move when the benefits far outweigh the costs.

comment:11 Changed 4 years ago by embray

The problem is that there's no cost to them not having a more standard packaging scheme--instead they're just pushing the cost on to everyone else who wants to help distribute their software.

Oh well--Jeroen is also right, I think, that there's no reason to tinker with GAP's installation layout in the Sage distribution unless there's a demonstrable need for it. But I think it's good to leave this ticket open for discussion.

comment:12 Changed 4 years ago by fbissey

My big ears tell me they are actually not interested in being packaged, so they don't really care about cost to anyone else.

Agree on keeping the status quo until something needs to be done.

comment:13 Changed 3 years ago by jdemeyer

  • Milestone changed from sage-wishlist to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

So, this can be closed then?

comment:14 Changed 3 years ago by dimpase

  • Reviewers set to Dima Pasechnik
  • Status changed from needs_review to positive_review

comment:15 Changed 3 years ago by embray

I still wish I had some answer as to why GAP thinks it needs to be special. But oh well, so does Sage (which I also don't have a completely satisfactory answer for tbh, other than "history").

comment:16 Changed 3 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.