Opened 5 years ago

Closed 5 years ago

#21757 closed defect (fixed)

Bug in reflection group to_matrix

Reported by: stumpc5 Owned by:
Priority: major Milestone: sage-7.5
Component: combinatorics Keywords: reflection group, gap3
Cc: chapoton Merged in:
Authors: Travis Scrimshaw Reviewers: Christian Stump
Report Upstream: N/A Work issues:
Branch: 89a6d45 (Commits, GitHub, GitLab) Commit: 89a6d45dc351c134c21ce983d92e28db0ceb347f
Dependencies: Stopgaps:

Status badges

Description (last modified by stumpc5)

The doctext

sage: W = ReflectionGroup((3,1,2))          # optional - gap3
sage: for w in W:                           # optional - gap3
....:     w.reduced_word()                  # optional - gap3
....:     [w.to_matrix(), w.to_matrix(on_space="dual")] # optional - gap3

used to work in

'SageMath version 7.3, Release Date: 2016-08-04'

and now breaks in

'SageMath version 7.4, Release Date: 2016-10-18'

Change History (5)

comment:1 Changed 5 years ago by stumpc5

  • Description modified (diff)

comment:2 Changed 5 years ago by tscrim

  • Authors set to Travis Scrimshaw
  • Branch set to public/combinat/fix_complex_refl_groups-21757
  • Cc chapoton added
  • Commit set to 89a6d45dc351c134c21ce983d92e28db0ceb347f
  • Status changed from new to needs_review

This was caused by an overly generous removal of keys() from families. I've added them back in (and cc-ing Frédéric so we are more careful about this in the future).


New commits:

89a6d45Adding back some overly generous removal of keys from families.

comment:3 Changed 5 years ago by stumpc5

Great, thanks for the fix! I will review it once I have some spare cpu/memory...

comment:4 Changed 5 years ago by stumpc5

  • Reviewers set to Christian Stump
  • Status changed from needs_review to positive_review

sage builds and tests pass

comment:5 Changed 5 years ago by vbraun

  • Branch changed from public/combinat/fix_complex_refl_groups-21757 to 89a6d45dc351c134c21ce983d92e28db0ceb347f
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.