Opened 4 years ago

Closed 4 years ago

#21712 closed defect (duplicate)

attach() EINTR with signal handlers

Reported by: vbraun Owned by:
Priority: major Milestone: sage-7.5
Component: user interface Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

E.g. resizing a terminal while file is attached crashes with

  File "/mnt/disk/home/release/Sage/local/lib/python2.7/site-packages/sage/repl/inputhook.py", line 34, in sage_inputhook
    r, w, e = select.select([f], [], [], TIMEOUT)
select.error: (4, 'Interrupted system call')

Change History (1)

comment:1 Changed 4 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21711

Note: See TracTickets for help on using tickets.