Opened 6 years ago

Closed 6 years ago

#21702 closed defect (worksforme)

Segfault with fraction field of multivariate ZZ polynomials as base ring of symmetric functions

Reported by: tscrim Owned by:
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: cython Keywords:
Cc: fbissey Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

We have the following:

sage: SymmetricFunctions(FractionField(QQ['q','t']))
Symmetric Functions over Fraction Field of Multivariate Polynomial Ring in q, t over Rational Field
sage: SymmetricFunctions(FractionField(ZZ['q']))
Symmetric Functions over Fraction Field of Univariate Polynomial Ring in q over Integer Ring
sage: SymmetricFunctions(FractionField(ZZ['q','t']))
Segmentation fault (core dumped)

However, the last one works with Sage 7.3.

Attachments (1)

sym_trace.log (9.9 KB) - added by tscrim 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by tscrim

I don't think this is caused by #12439 as the trace goes through libsingular.

comment:2 Changed 6 years ago by tscrim

Summary: symmetrica segfaults with fraction field of multivariate ZZ polynomialsSegfault with fraction field of multivariate ZZ polynomials as base ring of symmetric functions

comment:3 Changed 6 years ago by fbissey

trace?

Changed 6 years ago by tscrim

Attachment: sym_trace.log added

comment:4 Changed 6 years ago by tscrim

Attached.

comment:5 Changed 6 years ago by jdemeyer

Works for me on Sage 7.4.rc1:

sage: SymmetricFunctions(FractionField(QQ['q','t']))
Symmetric Functions over Fraction Field of Multivariate Polynomial Ring in q, t over Rational Field
sage: SymmetricFunctions(FractionField(ZZ['q']))
Symmetric Functions over Fraction Field of Univariate Polynomial Ring in q over Integer Ring
sage: SymmetricFunctions(FractionField(ZZ['q','t']))
Symmetric Functions over Fraction Field of Multivariate Polynomial Ring in q, t over Integer Ring

comment:6 Changed 6 years ago by tscrim

That's good to know but slightly unsettling at the same time. I forced a rebuild of symmetrica once I saw this, but I'm now convinced that is not the problem. Maybe it's something with the compiler? I used gcc 5.4.0 to build Sage. Although I guess we should wait to try and diagnose this further once 7.5.beta0 comes out, which should have Singular 4.

comment:7 Changed 6 years ago by tscrim

Milestone: sage-7.5sage-duplicate/invalid/wontfix
Status: newneeds_review

Hmm...this now is working for me now that I bumped to 7.4.rc2. I might have just done something to mess up my install when testing stuff... So perhaps we should just close this as invalid.

comment:8 Changed 6 years ago by jdemeyer

Resolution: worksforme
Status: needs_reviewclosed
Note: See TracTickets for help on using tickets.