Opened 6 years ago

Last modified 6 years ago

#21653 closed enhancement

Upgrade cysignals — at Version 3

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-7.5
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Jeroen Demeyer Reviewers:
Report Upstream: N/A Work issues:
Branch: u/jdemeyer/upgrade_cysignals (Commits, GitHub, GitLab) Commit: 39d0f013b327579c4e83a5e4b422ca00a61a95d3
Dependencies: #21441 Stopgaps:

Status badges

Description (last modified by jdemeyer)

This upgrades cysignals to version 1.3.0.

It also improves the build of cysignals:

  • Add support for SAGE_DEBUG=yes
  • Use pip instead of distutils

Upstream: https://pypi.python.org/packages/26/86/22ada529da644dfe7a8a40feeee7f854ed2dae7ca50a6cf6793264e2dcf2/cysignals-1.2.0.tar.bz2

Change History (3)

comment:1 Changed 6 years ago by jdemeyer

  • Branch set to u/jdemeyer/upgrade_cysignals

comment:2 Changed 6 years ago by jdemeyer

  • Commit set to 39d0f013b327579c4e83a5e4b422ca00a61a95d3
  • Status changed from new to needs_review

New commits:

ccd9442Add a sage-pip-install wrapper for pip which handles uninstallation better.
29957faVarious fixes and simplifications to sage-pip-install
783cd7dRe-install all pip-installed packages
8fd8273Fix various dependencies
77a70ceUpgrade to cysignals-1.2.0
39d0f01Use pip to install cysignals; support SAGE_DEBUG

comment:3 Changed 6 years ago by jdemeyer

  • Description modified (diff)
  • Milestone changed from sage-7.4 to sage-7.5
  • Status changed from needs_review to needs_work
Note: See TracTickets for help on using tickets.