Opened 3 years ago

Closed 3 years ago

#21608 closed defect (fixed)

Univariate Polynomial Ring does not support lc, lm, lt

Reported by: drhaley Owned by:
Priority: major Milestone: sage-7.5
Component: commutative algebra Keywords: ucd-mat165-2016
Cc: mkoeppe, yzh, tscrim, dimpase Merged in:
Authors: Yuan Zhou Reviewers: Matthias Koeppe
Report Upstream: N/A Work issues:
Branch: 96efafe (Commits) Commit: 96efafee6344a657047df8b2d117c34b162d4dcc
Dependencies: Stopgaps:

Description (last modified by yzh)

The following useful methods lc, lm, lt, monomial_coefficient, monomials and gradient are defined for multivariate polynomial rings, but are missing (or having different names) for univariate polynomial rings.

Change History (12)

comment:1 Changed 3 years ago by mkoeppe

  • Cc mkoeppe added
  • Keywords ucd-mat165-2016 added
  • Priority changed from minor to major

comment:2 Changed 3 years ago by yzh

  • Cc yzh added
  • Description modified (diff)

comment:3 Changed 3 years ago by yzh

  • Description modified (diff)

comment:4 Changed 3 years ago by yzh

  • Description modified (diff)

The method coefficient doesn't make much sense for univariate polynomials. One would rather use monomial_coefficient.

comment:5 Changed 3 years ago by yzh

  • Branch set to u/yzh/univariate_polynomial_ring_does_not_support_lc__lm__lt

comment:6 Changed 3 years ago by yzh

  • Authors set to Yuan Zhou
  • Commit set to a7fcd0ac8cdbe8c6f2bd6034e4acee4fed3ea892
  • Status changed from new to needs_review

New commits:

4fa8401add methods lc, lm, lt for univariate polynomials
2ebaa65add method monomial_coefficient for univariate polynomials
c25d334add method gradient for univariate polynomials
a7fcd0aadd method monomials for univariate polynomials

comment:7 Changed 3 years ago by mkoeppe

  • Status changed from needs_review to needs_work

Docstring of gradient should be clarified -- there's only 1 partial derivative. Docstring of lm is wrong.

comment:8 Changed 3 years ago by git

  • Commit changed from a7fcd0ac8cdbe8c6f2bd6034e4acee4fed3ea892 to 96efafee6344a657047df8b2d117c34b162d4dcc

Branch pushed to git repo; I updated commit sha1. New commits:

96efafefix errors in docstrings

comment:9 Changed 3 years ago by mkoeppe

  • Cc tscrim dimpase added
  • Status changed from needs_work to needs_review

comment:10 Changed 3 years ago by mkoeppe

This looks good to me. But since the new methodlc is now a duplicate of leading_coefficient in univariate polynomial rings (to be compatible with multivariate polynomial rings' method lc, I'm wondering if:

  • leading_coefficient should be deprecated or
  • also the alias leading_coefficient should be supplied for the multivariate case.

comment:11 Changed 3 years ago by mkoeppe

  • Milestone changed from sage-7.4 to sage-7.5
  • Reviewers set to Matthias Koeppe
  • Status changed from needs_review to positive_review

comment:12 Changed 3 years ago by vbraun

  • Branch changed from u/yzh/univariate_polynomial_ring_does_not_support_lc__lm__lt to 96efafee6344a657047df8b2d117c34b162d4dcc
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.