Opened 4 years ago

Closed 3 years ago

#21510 closed task (invalid)

trouble with sage_started.txt

Reported by: felixs Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: jdemeyer, fbissey, mkoeppe Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

some file, sage_started.txt is falling on our feet in #15105.

the file is created by the build process in SAGE_ETC, which possibly is not writable at that time.

also, the file seems to have something to do with the first run of the sage script. the first run must be possible to happen before installing anything (such as in make check).

it seems that we need a sort of wrapper to implement a functional pre-install sage. this wrapper could also handle sage_started, or disable the mechanism.

Change History (4)

comment:1 Changed 4 years ago by jdemeyer

What exactly is the problem to be fixed here? "foo is falling on our feet" is not very descriptive. You really need to give more details. Also, when you say things like "SAGE_ETC, which possibly is not writable at that time." you should justify that.

comment:2 Changed 4 years ago by jdemeyer

  • Description modified (diff)

comment:3 Changed 4 years ago by mkoeppe

The description should be clarified to distinguish the following issues:

  • What is sage_started.txt?
  • Does it belong into SAGE_LOCAL (= $prefix by #21479) or rather into the build directory (SAGE_ROOT, distinguished in VPATH builds (#21469) from SAGE_SRC_ROOT)?
  • If it does belong into SAGE_LOCAL, then if SAGE_LOCAL is only root-writable, then SAGE_SUDO needs to be invoked (#21537).
  • Beyond that, any discussion of "separating make and make install" should please go to ticket #21495, not here.

comment:4 Changed 3 years ago by jdemeyer

  • Milestone changed from sage-7.4 to sage-duplicate/invalid/wontfix
  • Resolution set to invalid
  • Status changed from new to closed

Closing because the issue isn't clear and no reply was given by the submitter after ample time.

Note: See TracTickets for help on using tickets.