Opened 5 years ago

Last modified 2 months ago

#21392 needs_work defect

Polynomial should implement quo_rem

Reported by: mmezzarobba Owned by:
Priority: minor Milestone: sage-9.5
Component: commutative algebra Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

There are implementations of quo_rem() in Polynomial_generic_dense and the like, but not in the Polynomial base class itself, so that specialized implementations of polynomials must implement it to work—while Polynomial does provide _add_, _mul_ etc.

Change History (5)

comment:1 Changed 10 months ago by mmezzarobba

  • Status changed from new to needs_review

fixed in #11593

comment:2 Changed 10 months ago by mmezzarobba

  • Milestone changed from sage-wishlist to sage-duplicate/invalid/wontfix

comment:3 Changed 8 months ago by chapoton

how could this be fixed long before the ticket was open ?

comment:4 Changed 8 months ago by mmezzarobba

  • Milestone changed from sage-duplicate/invalid/wontfix to sage-9.4
  • Status changed from needs_review to needs_work

Uh, good question! Apparently it has not been fixed: the ticket I am linking to adds a quo_rem() method to Polynomial_generic_dense, not Polynomial.

comment:5 Changed 2 months ago by mkoeppe

  • Milestone changed from sage-9.4 to sage-9.5

Setting a new milestone for this ticket based on a cursory review.

Note: See TracTickets for help on using tickets.