Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#21377 closed enhancement (fixed)

Update FriCAS to 1.3.2 (current)

Reported by: mantepse Owned by:
Priority: major Milestone: sage-8.1
Component: packages: experimental Keywords: FriCAS
Cc: dkrenn, mantepse, hemmecke, rws Merged in:
Authors: Frédéric Chapoton Reviewers: Martin Rubey
Report Upstream: N/A Work issues:
Branch: 8aa26de (Commits) Commit:
Dependencies: Stopgaps:

Description (last modified by chapoton)

subject says it all, see ​http://fricas.sourceforge.net/

https://groups.google.com/forum/#!topic/fricas-devel/jjn0P3H0N8g

I assume that this version needs less patching.

Upstream source tarball: https://sourceforge.net/projects/fricas/files/fricas/1.3.2/fricas-1.3.2-full.tar.bz2/download

(with ads, but automatic download after a few seconds)

Change History (26)

comment:1 Changed 3 years ago by mantepse

  • Description modified (diff)
  • Keywords FriCAS added
  • Milestone changed from sage-7.4 to sage-7.6
  • Summary changed from Update FriCAS to 1.3.0 (current) to Update FriCAS to 1.3.1 (current)

comment:2 Changed 3 years ago by chapoton

  • Branch set to u/chapoton/21377
  • Cc rws added
  • Commit set to d8be4f4a6de2a2cc66ff85ed598a1c42a8fb15ab
  • Milestone changed from sage-7.6 to sage-8.1

I made a branch, removing one patch that failed to apply. Maybe this patch must be kept.


New commits:

d8be4f4trac 21377 update fricas

comment:3 Changed 3 years ago by mantepse

Note that it's meanwhile 1.3.2. No idea whether there are significant changes.

comment:4 Changed 3 years ago by chapoton

  • Description modified (diff)
  • Summary changed from Update FriCAS to 1.3.1 (current) to Update FriCAS to 1.3.2 (current)

comment:5 Changed 3 years ago by git

  • Commit changed from d8be4f4a6de2a2cc66ff85ed598a1c42a8fb15ab to 8aa26de5e925a4b79eb460ca86c511d0a893e012

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

8aa26deupdate fricas to 1.3.2

comment:6 Changed 3 years ago by chapoton

  • Status changed from new to needs_review

comment:7 Changed 3 years ago by chapoton

This installs correctly and passes the "# optional fricas" doctests. Can someone double check please ?

comment:8 Changed 3 years ago by mantepse

I am currently compiling!

comment:9 Changed 3 years ago by mantepse

Hm, when trying to do sage -i fricas with this ticket, I get an error saying that it couldn't be downloaded...

How should I try this?

comment:10 Changed 3 years ago by mantepse

I think I figured it out: download and put it into upstream

comment:11 Changed 3 years ago by chapoton

you need to put yourself the tar file in $SAGEHOME/upstream

comment:12 Changed 3 years ago by mantepse

I actually have most tests failing now, because of bad indentation. For example:

File "src/sage/interfaces/fricas.py", line 1104, in sage.interfaces.fricas.FriCASElement._sage_
Failed example:
    a = fricas('(1 + sqrt(2))^5'); a                              # optional - fricas
Expected:
       +-+
    29\|2  + 41
Got:
    +-+
    29 \|2  + 41

However, I cannot tell whether the tests passed before the switch to FriCAS 1.3.2.

comment:13 Changed 3 years ago by hemmecke

I guess the "+-+" part got a bit shifted when you copied the result into the ticket. The difference is the space after 29. This has recently been added.

comment:14 Changed 3 years ago by mantepse

I am not sure how to proceed - on the one hand, I think it makes sense to merge this, because I do not know what made the output break (I do *not* mean the additional space) - it was broken before the upgrade, too.

Frederic, can you confirm that the tests pass on your computer? It's strange that the space introduced in FriCAS would not show up on your system.

comment:15 Changed 3 years ago by mantepse

  • Status changed from needs_review to positive_review

I can confirm it works and fixes part of #23782

comment:16 Changed 3 years ago by mantepse

  • Authors set to Frédéric Chapoton
  • Reviewers set to Martin Rubey

comment:17 in reply to: ↑ description ; follow-up: Changed 3 years ago by jdemeyer

Replying to mantepse:

(with ads, but automatic download after a few seconds)

I'm not sure that this will be acceptable for the release manager.

comment:18 in reply to: ↑ 17 ; follow-up: Changed 3 years ago by mantepse

Replying to jdemeyer:

Replying to mantepse:

(with ads, but automatic download after a few seconds)

I'm not sure that this will be acceptable for the release manager.

Are you saying that sourceforge is not acceptable anymore?

comment:19 in reply to: ↑ 18 Changed 3 years ago by rws

Replying to mantepse:

Are you saying that sourceforge is not acceptable anymore?

https://en.wikipedia.org/wiki/SourceForge#Country_restrictions

They seem to at least willing to improve the site that declined after 2012: https://www.reddit.com/r/sysadmin/comments/4n3e1s/the_state_of_sourceforge_since_its_acquisition_in/

comment:20 Changed 3 years ago by mantepse

Is https://github.com/fricas/fricas acceptable? But I have no idea how to package from there.

comment:21 follow-up: Changed 3 years ago by hemmecke

Note that https://github.com/fricas/fricas is a only source repository. As far as I know, the release tarball is not identical to the git version that is tagged with the version number. The release tarball contains some precompiled stuff. (I'm not 100% sure since I compile myself from source.) Ask on https://groups.google.com/forum/#!forum/fricas-devel how one can package from the source tree.

comment:22 Changed 3 years ago by mantepse

OK, I shot myself into the foot here. No, I'm sure we should want the sourceforge version here. PLEASE!

Last edited 3 years ago by mantepse (previous) (diff)

comment:23 in reply to: ↑ 21 Changed 3 years ago by rws

Replying to hemmecke:

Note that https://github.com/fricas/fricas is a only source repository.

So is https://github.com/pynac/pynac. The maintainer just uploads a suitable tarball when doing a release. This means you need to do at least one release in the repo.

comment:24 Changed 3 years ago by jdemeyer

I am not the release manager. I am only saying that it might be a problem for the release manager, just to save you some time before the release manager looks at this ticket.

comment:25 Changed 3 years ago by vbraun

  • Branch changed from u/chapoton/21377 to 8aa26de5e925a4b79eb460ca86c511d0a893e012
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:26 Changed 3 years ago by mantepse

  • Commit 8aa26de5e925a4b79eb460ca86c511d0a893e012 deleted

This is wonderful, wonderful, wonderful! Thank you!

Note: See TracTickets for help on using tickets.