Opened 6 years ago

Last modified 6 years ago

#21256 closed enhancement

Upgrade and fix ipywidgets — at Version 9

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-7.4
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Jeroen Demeyer Reviewers:
Report Upstream: N/A Work issues:
Branch: u/jdemeyer/upgrade_ipywidgets_to_version_5_2_2 (Commits, GitHub, GitLab) Commit: 3fcd5b34fe0fa44c9a88fd8c66e39bc61ceb1dc0
Dependencies: #20218 Stopgaps:

Status badges

Description (last modified by jdemeyer)

There are two issues with widgetsnbextension:

  1. It must be installed using pip. The typical python setup.py install does not work. See https://github.com/ipython/ipywidgets/issues/718. This is fixed by #20218.
  1. We need to enable the widgetsnbextension for ipywidgets to actually work.

Tarballs:

Change History (9)

comment:1 Changed 6 years ago by jdemeyer

  • Description modified (diff)

comment:2 Changed 6 years ago by jdemeyer

  • Branch set to u/jdemeyer/upgrade_ipywidgets_to_version_5_2_2

comment:3 Changed 6 years ago by jdemeyer

  • Commit set to 7aa94b615cc598fa1a708920ea0be4682e8c3f0f
  • Description modified (diff)
  • Summary changed from Upgrade ipywidgets to version 5.2.2 to Upgrade and fix ipywidgets

New commits:

7aa94b6Upgrade ipywidgets to version 5.2.2

comment:4 Changed 6 years ago by jdemeyer

  • Description modified (diff)

comment:5 Changed 6 years ago by jdemeyer

  • Dependencies set to #20218
  • Description modified (diff)

comment:6 Changed 6 years ago by git

  • Commit changed from 7aa94b615cc598fa1a708920ea0be4682e8c3f0f to b37edb2e44e3abd770a440704f5e384746f0e8da

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

b37edb2Upgrade and fix ipywidgets

comment:7 Changed 6 years ago by jdemeyer

  • Description modified (diff)

comment:8 Changed 6 years ago by git

  • Commit changed from b37edb2e44e3abd770a440704f5e384746f0e8da to 3fcd5b34fe0fa44c9a88fd8c66e39bc61ceb1dc0

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

6c9dffeUse pip to install most Python-based dependencies; see http://trac.sagemath.org/ticket/20218
63cade4This is no longer needed.
a692a30Update some packages that were added since the start of this branch to use pip.
3e16e00Some of the packages changed to use pip in 2fe1d357600e60d3422141ba5a7fb16efb3a691b needed pip added to their build deps.
332d915Move PIP_INSTALL into sage-env so that it's available so long as the Sage environment is activated
d6121b2pip install sagenb_exports
d7218a0Three new Python packages were added that should use pip for installation
3fcd5b3Upgrade and fix ipywidgets

comment:9 Changed 6 years ago by jdemeyer

  • Description modified (diff)
Note: See TracTickets for help on using tickets.