Opened 5 years ago

Closed 5 years ago

#21193 closed enhancement (fixed)

remove \atop and \choose

Reported by: chapoton Owned by:
Priority: minor Milestone: sage-7.4
Component: documentation Keywords:
Cc: Merged in:
Authors: Frédéric Chapoton Reviewers: André Apitzsch
Report Upstream: N/A Work issues:
Branch: 8b488cc (Commits, GitHub, GitLab) Commit: 8b488cce9aa6a9c9c727afccb1de21ca267d1ad1
Dependencies: Stopgaps:

Status badges

Description

Those old-style latex expressions are giving pdf warnings.

Change History (16)

comment:1 Changed 5 years ago by chapoton

  • Branch set to public/21193
  • Commit set to 848759e44c63903327e635d656563d6686c9f32a

New commits:

848759eremove all \atop and \choose (as deprecated latex)

comment:2 Changed 5 years ago by chapoton

  • Status changed from new to needs_review

comment:3 Changed 5 years ago by aapitzsch

  • Reviewers set to André Apitzsch
  • Status changed from needs_review to needs_work

Could you remove the needless ) (after \binom{n+1}{2}) from

@@ -6578,7 +6575,7 @@ class A000204(SloaneSequence):
 class A000217(SloaneSequence):
     def __init__(self):
         r"""
-        Triangular numbers: `a(n) = {n+1} \choose 2) = n(n+1)/2`.
+        Triangular numbers: `a(n) = \binom{n+1}{2}) = n(n+1)/2`.
 
         INPUT:
 

comment:4 Changed 5 years ago by git

  • Commit changed from 848759e44c63903327e635d656563d6686c9f32a to 0659590941803923118ab0fbecb001b41bb6e328

Branch pushed to git repo; I updated commit sha1. New commits:

0659590trac 21193 detail

comment:5 Changed 5 years ago by chapoton

  • Status changed from needs_work to needs_review

done

comment:6 Changed 5 years ago by aapitzsch

  • Status changed from needs_review to positive_review

comment:7 Changed 5 years ago by vbraun

  • Status changed from positive_review to needs_work
[docpdf] Package amsmath Warning: Foreign command \over;
[docpdf] (amsmath)                \frac or \genfrac should be used instead
[docpdf] (amsmath)                 on input line 12615.
[docpdf] 
[docpdf] [143] [144]
[docpdf] 
[docpdf] ! Package inputenc Error: Keyboard character used is undefined
[docpdf] (inputenc)                in inputencoding `utf8'.
[docpdf] 
[docpdf] See the inputenc package documentation for explanation.
[docpdf] Type  H <return>  for immediate help.
[docpdf]  ...                                              
[docpdf]                                                   
[docpdf] l.12766 ...inom{x}{j}^^Hinom{n-x}{l-j},\end{split}
[docpdf]                                                   
[docpdf] ? 
[docpdf] ! Emergency stop.
[docpdf]  ...                                              
[docpdf]                                                   
[docpdf] l.12766 ...inom{x}{j}^^Hinom{n-x}{l-j},\end{split}
[docpdf]                                                   
[docpdf] !  ==> Fatal error occurred, no output PDF file produced!
[docpdf] Transcript written on coding.log.
[docpdf] Makefile:68: recipe for target 'coding.pdf' failed
[docpdf] make[2]: *** [coding.pdf] Error 1
[docpdf] make[2]: Leaving directory '/mnt/disk/home/buildslave-sage/slave/sage_git/build/local/share/doc/sage/latex/en/reference/coding'
[docpdf] Error building the documentation.

comment:8 Changed 5 years ago by git

  • Commit changed from 0659590941803923118ab0fbecb001b41bb6e328 to 3371add1a7de1b1d0dc1efa1b18bed7faf1f6c3e

Branch pushed to git repo; I updated commit sha1. New commits:

11b953cMerge branch 'public/21193' in 7.4.b0
3371addtrac #21193 trying to fix pdf issue

comment:9 Changed 5 years ago by chapoton

Not clear to me what the issue is. And the pdf doc builds fine for me.

I have tried to use a raw string for the doc. If this does not work, maybe the file should be declared utf8 ?

comment:10 Changed 5 years ago by git

  • Commit changed from 3371add1a7de1b1d0dc1efa1b18bed7faf1f6c3e to c519fe613d583630a2c7957335c05170a76c531b

Branch pushed to git repo; I updated commit sha1. New commits:

c519fe6trac 21193 more work on doc of delsarte bounds

comment:11 Changed 5 years ago by chapoton

  • Status changed from needs_work to needs_review

I did my best to prevent pdf problems.

comment:12 Changed 5 years ago by aapitzsch

I still get a similar error like Volker, caused by changes in src/sage/matroids/basis_matroid.pyx and src/sage/matroids/circuit_closures_matroid.pyx.

I used pdflatex from TeX Live 2016.

comment:13 Changed 5 years ago by git

  • Commit changed from c519fe613d583630a2c7957335c05170a76c531b to 8b488cce9aa6a9c9c727afccb1de21ca267d1ad1

Branch pushed to git repo; I updated commit sha1. New commits:

e4db2feMerge branch 'public/21193' in 7.4.b1
8b488cctrac 21193 adding r(aw) to doc chains

comment:14 follow-up: Changed 5 years ago by chapoton

does this latest commit (on top of 7.4.b1) solve the issue ?

comment:15 in reply to: ↑ 14 Changed 5 years ago by aapitzsch

  • Status changed from needs_review to positive_review

Replying to chapoton:

does this latest commit (on top of 7.4.b1) solve the issue ?

Yes.

comment:16 Changed 5 years ago by vbraun

  • Branch changed from public/21193 to 8b488cce9aa6a9c9c727afccb1de21ca267d1ad1
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.