Opened 13 years ago

Closed 12 years ago

#2117 closed defect (invalid)

problems with "...?starup_token=..." URL in notebook

Reported by: nbruin Owned by: boothby
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The following sequence of events leads to a "Internal Server Error" page:

  • Start up sage to serve a local notebook (sage -notebook)

[Browser pops up with "admin" already logged in, using a "startup_token" url]

  • select some worksheets
  • click "archive"

The notebook seems to be in a sane condition afterwards. If I change the URL to "https://localhost:8001/" (i.e., remove the "?startup_token=..." part) everything seems as it should be. I guess the notebook barfs at this stage on the "?" part in the URL?

Change History (3)

comment:1 Changed 12 years ago by mhansen

  • Milestone changed from sage-3.4.1 to sage-duplicate/invalid/wontfix
  • Resolution set to invalid
  • Status changed from new to closed

As we don't get the URL at the beginning with the startup token, I'm going to mark this as invalid. I can't reproduce it in 3.2.3.

comment:2 Changed 12 years ago by mabshoff

  • Milestone changed from sage-duplicate/invalid/wontfix to sage-3.4.1
  • Resolution invalid deleted
  • Status changed from closed to reopened

This came up last week on sage-edu with Sage 3.2.3, so there is certainly a bug to be found and fixed here. It was reproducible with a wiped .sage by someone who seemed technically competent enough not to make a dumb mistake. So I am reopening this.

Cheers,

Michael

comment:3 Changed 12 years ago by mhansen

  • Milestone changed from sage-3.4.1 to sage-duplicate/invalid/wontfix
  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.