Opened 5 years ago

Closed 3 years ago

#21095 closed defect (invalid)

Slowness in exactification

Reported by: vdelecroix Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords:
Cc: Merged in:
Authors: Reviewers: Vincent Delecroix
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

On sage-7.3.beta9

sage: x = polygen(ZZ)
sage: p = 67*x^4 - 33*x^3 + 94*x^2 - 30*x + 57
sage: r = p.roots(QQbar, multiplicities=False)
sage: r[0].abs().exactify()  # <- takes forever

Change History (3)

comment:1 Changed 3 years ago by mmezzarobba

  • Milestone changed from sage-7.3 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

duplicate of #15600

comment:2 Changed 3 years ago by vdelecroix

  • Reviewers set to Vincent Delecroix
  • Status changed from needs_review to positive_review

comment:3 Changed 3 years ago by embray

  • Resolution set to invalid
  • Status changed from positive_review to closed

Presuming these are all correctly reviewed as either duplicate, invalid, or wontfix.

Note: See TracTickets for help on using tickets.