Opened 3 years ago

Closed 3 years ago

#21077 closed defect (fixed)

failing doctests with optional package coxeter 3

Reported by: vdelecroix Owned by:
Priority: critical Milestone: sage-7.3
Component: packages: optional Keywords:
Cc: tscrim, chapoton, aschilling, andrew.mathas, nthiery Merged in:
Authors: Travis Scrimshaw Reviewers: Vincent Delecroix
Report Upstream: N/A Work issues:
Branch: 312462a (Commits) Commit: 312462a7b4fb8b7492dffbe5e8798b63b66ea0bc
Dependencies: Stopgaps:

Description

With coxeter3 installed

sage: W = CoxeterGroup(['B', 3], implementation='coxeter3')
Traceback (most recent call last):
...
.../coxeter3/coxeter.pyx in sage.libs.coxeter3.coxeter.CoxGroup.__cinit__ (.../cythonized/sage/libs/coxeter3/coxeter.cpp:3329)()
    266
    267         if len(cartan_type) == 2:
--> 268             type, rank = cartan_type
    269         else:
    270             type, rank, affine = cartan_type
ValueError: too many values to unpack (expected 2)

And indeed

sage: c = CartanType('B3')
sage: len(c)
2
sage: len(list(c))
3

This causes many doctest failures.

Change History (5)

comment:1 Changed 3 years ago by vdelecroix

  • Summary changed from failing doctest with optional package coxeter 3 to failing doctests with optional package coxeter 3

comment:2 Changed 3 years ago by tscrim

  • Authors set to Travis Scrimshaw
  • Cc andrew.mathas nthiery added; stumpc5 removed

This is caused by #20973 and is independent of coxeter3. I will post a fix shortly.

comment:3 Changed 3 years ago by tscrim

  • Branch set to public/combinat/root_system/fix_cartan_type-20177
  • Commit set to 312462a7b4fb8b7492dffbe5e8798b63b66ea0bc
  • Status changed from new to needs_review

The problem is that there is an affine method for finite Cartan types that returns the corresponding affine type, whereas for affine types, the twist number is in the attribute affine. We already override __getitem__ for affine Cartan types, so we just default to 2 valid indices for the general __getitem__.


New commits:

312462aFixing __getitem__ for non-affine Cartan types.

comment:4 Changed 3 years ago by vdelecroix

  • Reviewers set to Vincent Delecroix
  • Status changed from needs_review to positive_review

At least the optional doctest now pass ;-)

comment:5 Changed 3 years ago by vbraun

  • Branch changed from public/combinat/root_system/fix_cartan_type-20177 to 312462a7b4fb8b7492dffbe5e8798b63b66ea0bc
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.