Opened 13 years ago

Closed 12 years ago

#2106 closed enhancement (duplicate)

Implement univariate polynomials over GF(2) via ntl.GF2X

Reported by: malb Owned by: somebody
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: basic arithmetic Keywords:
Cc: malb Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Marshall Buck on [sage-support] writes:

It is a shame that normal arithmetic for polys over GF(2) still seems to be implemented by the ntl ZZ_pX library, which is usually at least 10 times slower than GF2X, up to degree 217 anyway. In that range GF2X matches the speed of magma.

Change History (2)

comment:1 Changed 12 years ago by zimmerma

  • Cc malb added

This is related to #4302, and will probably be fixed with #4302, thus might be marked as duplicate of #4302.

comment:2 Changed 12 years ago by malb

  • Milestone changed from sage-3.2.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate #4302

Note: See TracTickets for help on using tickets.