Opened 3 years ago

Closed 3 years ago

#21034 closed enhancement (fixed)

Upgrade to pynac-0.6.8

Reported by: rws Owned by:
Priority: major Milestone: sage-7.3
Component: packages: standard Keywords:
Cc: paulmasson Merged in:
Authors: Ralf Stephan Reviewers: Paul Masson
Report Upstream: N/A Work issues:
Branch: 0eb21db (Commits) Commit: 0eb21dba0085b87817298a1b7042c75ad2c6b2ae
Dependencies: Stopgaps:

Description (last modified by paulmasson)

The new Pynac version does:

  • fix polylog evalf (Sage #18386)
  • better beta_evalf() (Sage #15196)
  • fix bug in cancelling of fractions (Sage #19775, #20843)
  • fix some positive/nonnegative bugs
  • do not ignore _print_latex_() in GinacFunctions (#20888)
  • provide Pynac version of Maxima's ex.coefficients()
  • provide Pynac version of Maxima's ex.combine()
  • some fixes ported from GiNaC

https://github.com/pynac/pynac/releases/download/pynac-0.6.8/pynac-0.6.8.tar.bz2

Change History (23)

comment:1 Changed 3 years ago by rws

  • Branch set to u/rws/upgrade_to_pynac_0_6_8

comment:2 Changed 3 years ago by rws

  • Authors set to Ralf Stephan
  • Cc paulmasson added
  • Commit set to 3784da9e71986de287be1d6c3dca0f1d3473ead3
  • Description modified (diff)
  • Status changed from new to needs_review

New commits:

7fd4370pkg version / checksum
2f43ed9use Pynac instead of Maxima in ex.coefficients() and combine()
3784da9doc and doctest changes

comment:3 follow-up: Changed 3 years ago by paulmasson

Started from a clean copy of 7.3.beta8 develop and pulled in changes for this ticket. Ran make and got this error:

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

* package: sagelib-7.3.beta5
  log file: /Users/Masson/Downloads/GitHub/sage/logs/pkgs/sagelib-7.3.beta5.log
  build directory: /Users/Masson/Downloads/GitHub/sage/local/var/tmp/sage/build/sagelib-7.3.beta5

Ran make again on develop with no problem.

comment:4 Changed 3 years ago by paulmasson

  • Reviewers set to Paul Masson

comment:5 Changed 3 years ago by rws

  • Description modified (diff)

comment:6 Changed 3 years ago by paulmasson

Any update on the 7.3.beta5 error message? Something on my end or yours?

comment:7 in reply to: ↑ 3 Changed 3 years ago by rws

Replying to paulmasson:

Started from a clean copy of 7.3.beta8 develop and pulled in changes for this ticket.

How did you "pull in" the changes? BTW, if you do git trac checkout 21034 you will always get the Sage version of the branch in 21034, regardless of your develop. Also a hint: make start will skip building the expensive step of building the docs.

You should also download the pynac tarball and copy it into upstream/ before making.

comment:8 Changed 3 years ago by paulmasson

Originally did git trac pull 21034. This time did git trach checkout 21034 and getting same error. Then also copied pynac tarball to upstream folder and still getting error. Last bit not building is this:

[sagelib-7.3.beta8] [3/9] gcc -fno-strict-aliasing -I/Users/Masson/Downloads/GitHub/sage/local/var/tmp/sage/build/python2-2.7.10.p2/include -DNDEBUG -g -fwrapv -O3 -Wall -Wno-unused -I/Users/Masson/Downloads/GitHub/sage/local/include -I/Users/Masson/Downloads/GitHub/sage/local/include/python2.7 -I/Users/Masson/Downloads/GitHub/sage/local/lib/python2.7/site-packages/numpy/core/include -I/Users/Masson/Downloads/GitHub/sage/src -I/Users/Masson/Downloads/GitHub/sage/src/sage/ext -I/Users/Masson/Downloads/GitHub/sage/src/build/cythonized -I/Users/Masson/Downloads/GitHub/sage/src/build/cythonized/sage/ext -I/Users/Masson/Downloads/GitHub/sage/local/include/python2.7 -c /Users/Masson/Downloads/GitHub/sage/src/build/cythonized/sage/symbolic/getitem.cpp -o build/temp.macosx-10.9-x86_64-2.7/Users/Masson/Downloads/GitHub/sage/src/build/cythonized/sage/symbolic/getitem.o -std=c++11 -fno-strict-aliasing
[sagelib-7.3.beta8] error: command 'gcc' failed with exit status 1
[sagelib-7.3.beta8] make[3]: *** [sage] Error 1

Can't review until it builds completely.

comment:9 Changed 3 years ago by rws

In comment:5 you write about starting from beta8 but the output shows beta5. Can you please confirm that beta8 develop compiles cleanly? I'm asking because on the sage-devel there are several reports about problems of beta8 on MacOS.

comment:10 Changed 3 years ago by paulmasson

7.3.beta8 develop compiles cleanly on Mac OS X El Capitan

comment:11 Changed 3 years ago by git

  • Commit changed from 3784da9e71986de287be1d6c3dca0f1d3473ead3 to 0eb21dba0085b87817298a1b7042c75ad2c6b2ae

Branch pushed to git repo; I updated commit sha1. New commits:

0eb21dbMerge branch 'develop' into t/21034/upgrade_to_pynac_0_6_8

comment:12 Changed 3 years ago by rws

beta9 is now merged into the branch and has all recent MacOS fixes. Please either do git trac pull 21034 in your local copy of this branch, or delete your local copy of this branch and do a git trac checkout 21034. And try again.

comment:13 Changed 3 years ago by paulmasson

Sorry Ralf, but still getting the error. Curiously even though it references "sagelib-7.3.beta5.log" this file hasn't been modified building either beta8 or beta9.

Before you ask, 7.3.beta9 develop also compiles cleanly on Mac OS X El Capitan.

Looking back to the pynac 0.6.7 upgrade, there is a comment from Travis that looks relevant. This prompted me to see which beta included 0.6.7 and sure enough it was beta5.

I'll be the first to admit knowing nothing about building tarballs, but are you sure there isn't a problem there? The tarball for 0.6.8 isn't downloading automatically to the upstream folder.

comment:14 Changed 3 years ago by rws

Paul, Sage cannot download pynac-0.6.8 because this is only possible after this ticket is merged. As a reviewer you need to download manually and copy it into upstream. Note however that the tarball might be deleted again by Sage at some time. So always make sure it's there before compiling this branch.

comment:15 Changed 3 years ago by paulmasson

This time I downloaded the tarball to upstream, deleted the local branch, did git trac checkout 21034, confirmed the tarball was in place and ran make. Unfortunately, same error. Tarball still there after make errors out. What now?

comment:16 Changed 3 years ago by paulmasson

In an effort to move this forward, I did make distclean followed by make. The latter fails for both master and develop, so there are Mac issues at play. Will report on sage-devel.

Last edited 3 years ago by paulmasson (previous) (diff)

comment:17 Changed 3 years ago by paulmasson

Not a Mac problem after all. I accidentally merged #21006 some time ago which left behind an empty package folder named "prompt_toolkit". Any package following it alphabetically was ignored, including pynac.

comment:18 Changed 3 years ago by paulmasson

Finally built this ticket! Some preliminary questions:

1) The second plot in #18368 still throws an error. Have you modified the behavior of the zeta function in Pynac or just the polylog? If the latter, the doctest you included doesn't appear to address the problem with the zeta function on that ticket.

2) Numerical evaluation of the beta function looks good, so that fixes #15196. I have noticed however that evaluating the beta function at poles returns NaN rather than unsigned infinity. Is this something that needs to be addressed in Sage or Pynac?

3) The description of #20888 makes it sound like an existing LaTeX string in Pynac overrides one in Sage. Is that correct? If so, shouldn't entries in Sage always take precedence?

4) This ticket doesn't appear to change anything for #20455. Does that ticket need to be addressed in Sage using behavior now available from Pynac?

Will do more testing tomorrow. Thanks for putting up with my build issue.

comment:19 Changed 3 years ago by rws

  • Description modified (diff)

1) Yes, only part of #18368 is fixed, 2) the infinity problem has to be addressed in Sage and it's the same problem as #19439 so it should go in that ticket, 3) Yes, and this is only one example where Pynac code overrides Sage code (I don't think this is a problem in principle), 4) Good Question, in the process of implementation I had to revise my opinion, let's discuss that in #20455.

comment:20 Changed 3 years ago by paulmasson

  • Status changed from needs_review to positive_review

Doctests pass. Documentation builds. Outstanding issues will be addressed on indicated tickets.

Good to go.

comment:21 Changed 3 years ago by paulmasson

  • Description modified (diff)

Typo in ticket description referencing wrong ticket. Positive review stands.

comment:22 Changed 3 years ago by rws

Thanks for the review.

comment:23 Changed 3 years ago by vbraun

  • Branch changed from u/rws/upgrade_to_pynac_0_6_8 to 0eb21dba0085b87817298a1b7042c75ad2c6b2ae
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.