Opened 6 years ago

Closed 22 months ago

#21031 closed defect (wontfix)

"sage -package update" nukes checksums.ini on error

Reported by: Matthias Köppe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords: sd111
Cc: Volker Braun, Jeroen Demeyer Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Matthias Köppe)

When something goes wrong during sage -package update because of a typo, the checksums.ini file is left empty.

Example:

 ./sage -package update normaliz 3.1.1000

Change History (9)

comment:1 Changed 6 years ago by Matthias Köppe

Description: modified (diff)
Milestone: sage-7.3sage-7.6

comment:2 Changed 5 years ago by Matthias Köppe

Milestone: sage-7.6sage-8.1

comment:3 Changed 22 months ago by Matthias Köppe

Keywords: sd111 added

Hoping we can make progress on this ticket this week - https://wiki.sagemath.org/days111

comment:4 Changed 22 months ago by gh-kliem

I can't reproduce this. However, build/pkgs/normaliz/package-version.txt is changed regardless, which isn't optimal.

comment:5 Changed 22 months ago by gh-kliem

Authors: Jonathan Kliem
Branch: public/21031
Commit: 25c52fd778f1d15f4ed89844d5fa67f9e5c4f09d
Status: newneeds_review

New commits:

25c52fdrestore version number on failure

comment:6 Changed 22 months ago by gh-kliem

This at least restores the previous version number (or tries to).

I don't know, if it is worth it.

comment:7 Changed 22 months ago by Matthias Köppe

... probably adds too much complexity for what it adds

comment:8 Changed 22 months ago by gh-kliem

Authors: Jonathan Kliem
Branch: public/21031
Commit: 25c52fd778f1d15f4ed89844d5fa67f9e5c4f09d
Milestone: sage-8.1sage-duplicate/invalid/wontfix

Okay. The only use case would be a person having the sources but not in a git repository and trying to update. If this is the case, the person would have to fix the version number itself. I think this is ok.

comment:9 Changed 22 months ago by Frédéric Chapoton

Resolution: wontfix
Status: needs_reviewclosed
Note: See TracTickets for help on using tickets.