Opened 5 years ago

Closed 5 years ago

#20961 closed defect (fixed)

Fix pycrypto build on Cygwin

Reported by: embray Owned by:
Priority: major Milestone: sage-7.4
Component: porting: Cygwin Keywords: windows cygwin pycrypto
Cc: Merged in:
Authors: Erik Bray Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: 0092c74 (Commits, GitHub, GitLab) Commit: 0092c749be32c24482a73834d34254bc0786d70d
Dependencies: Stopgaps:

Status badges

Description (last modified by embray)

Without this patch (or something like it) pycrypto does not build on Cygwin. Please see the commit message for more detail.

This patch should almost certainly be applied only on Cygwin, as that's the only (common-ish) platform that is likely affected. The configuration that the patch is removing was claimed to be needed for FreeBSD and NetBSD, and I can't be sure what impact it has on other platforms (though it's probably harmless on Linux).

Attachments (1)

pycrypto-2.6.1.p1.log (23.3 KB) - added by tscrim 5 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 5 years ago by embray

  • Status changed from new to needs_review

comment:2 Changed 5 years ago by embray

  • Description modified (diff)

comment:3 Changed 5 years ago by tscrim

Looking at my log file (to be attached shortly), it doesn't seem like the patch was attempted to be installed on my Cygwin32.

Changed 5 years ago by tscrim

comment:4 Changed 5 years ago by embray

According to your log the patch is applying but you're having some other, possibly unrelated problem.

comment:5 Changed 5 years ago by tscrim

Ah, yes, it is applying and I missed it in the log. The errors are from these lines:

In file included from src/SHA256.c:35:0:
src/hash_SHA2.h:91:9: error: unknown type name 'U32'
typedef U32 sha2_word_t;
         ^
In file included from src/SHA256.c:72:0:
src/hash_SHA2_template.c:175:38: error: unknown type name 'U8'
hash_update (hash_state *self, const U8 *buf, int len)
                                      ^
In file included from src/hash_SHA2_template.c:199:0,
                 from src/SHA256.c:72:

Should we try and fix this problem here on this ticket as well?

Last edited 5 years ago by tscrim (previous) (diff)

comment:6 Changed 5 years ago by embray

I'd rather not, if anything just because I don't know what the issue is here and it probably isn't related. I'm also not spending any time on Cygwin32. *Unless* of course this is actually caused by the patch in this ticket and is fixed by removing it.

comment:7 Changed 5 years ago by tscrim

  • Milestone changed from sage-7.3 to sage-7.4
  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

It definitely is not caused by the patch since this failed for me without the patch.

comment:8 Changed 5 years ago by embray

Okay, thanks for checking.

comment:9 Changed 5 years ago by tscrim

Follow-up #21236.

comment:10 Changed 5 years ago by vbraun

  • Branch changed from u/embray/pycrypto-cygwin to 0092c749be32c24482a73834d34254bc0786d70d
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.