Opened 5 years ago

Last modified 5 years ago

#20901 closed defect

Upgrade bliss package to 0.73 with Debian patches; install header files in location expected by polymake — at Initial Version

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-7.3
Component: packages: optional Keywords:
Cc: azi, jdemeyer, vdelecroix, kcrisman, dimpase, chapoton, stumpc5, moritz, vbraun Merged in:
Authors: Reviewers:
Report Upstream: Reported upstream. No feedback yet. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

New upstream archive: http://www.tcs.hut.fi/Software/bliss/bliss-0.73.zip (we have 0.72)

Upstream bliss does not have a proper build system (in particular no 'make install'). "spkg-install" installs header files with generic names such as "graph.hh" flat into $SAGE_LOCAL/include/

Debian has https://packages.debian.org/sid/math/bliss which autotoolizes the package and adjust the include file location. This matches where Polymake (#20892) expects the header files.

We should really be using Debian as our upstream for this package.

Change History (0)

Note: See TracTickets for help on using tickets.