Changes between Initial Version and Version 1 of Ticket #20849, comment 4


Ignore:
Timestamp:
08/25/16 11:17:10 (5 years ago)
Author:
danielaugot
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #20849, comment 4

    initial v1  
    99- `minimum_distance` the new doc string is less clear than previous one. The notion of minimum distance is clear in coding theory, no need to be explicit. If you really want to explicit it, change the sentence of the new docstring to `Returns the minimum distance between any two words in ``self``.`
    1010
    11 - `parity_column_multipliers` the new docstring speaks about "positions scalars", while I guess it should be column multipliers, since the evaluation points are the same for the code and its dual.
     11- `column_multipliers`, `parity_column_multipliers`:  the new doc strings speaks about positions scalars, while these methods deal with multipliers.
    1212
    13 - `weight_enumerator`: it would be better to say "the polynomial whose coefficient of degree is [...]" this avoids naming the variable 'x'
     13- `weight_enumerator`: it would be better to say "the polynomial whose coefficient of degree is [...]" to avoid naming the variable 'x'
    1414
    15 - (several places) the framework for describing the encoding could be made a bit more clear, using the vocables "message" and "encoding" more explicitly. Instead of
     15- (several places) the framework for describing the encoding could be made a bit more clear, using the terms "message" and "encoding" more explicitly. Instead of
    1616
    1717{{{
     
    2222what about
    2323{{{
    24 let `m[...] over F` be the message
     24let `m=[...]` a vector over F be the message:
    2525[...]
    2626the encoding of `m` will be the following codeword:
    2727}}}
     28- `class GRSErrorErasureDecoder(Decoder)` it would be better to say : floor((d-1)/2 instead of "decoding radius". Also the input to the decode method should be a `word_and_erasure` vector, not a vector `y`.
     29
     30Daniel