Opened 7 years ago

Closed 22 months ago

#20764 closed enhancement (duplicate)

parking functions without CombinatorialClass

Reported by: Frédéric Chapoton Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords: parking
Cc: Mike Zabrocki, Travis Scrimshaw Merged in:
Authors: Reviewers: Frédéric Chapoton
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

another try at modernizing parking functions

see #15216 for another proposal

Change History (11)

comment:1 Changed 7 years ago by Frédéric Chapoton

Branch: public/20764
Commit: 109c4e59d4d07074accbc9fc0406432c69da7bdd

New commits:

109c4e5modernizing parking functions (WIP)

comment:2 Changed 7 years ago by git

Commit: 109c4e59d4d07074accbc9fc0406432c69da7bdd38266456e79eb0afc81f4de28d930a7d343603e5

Branch pushed to git repo; I updated commit sha1. New commits:

3826645trac 20764 some details, add TestSuite

comment:3 Changed 7 years ago by git

Commit: 38266456e79eb0afc81f4de28d930a7d343603e51791d2750d21d69d028219e399ac95f757ab4a0f

Branch pushed to git repo; I updated commit sha1. New commits:

1791d27trac 20764 solving some issues

comment:4 Changed 7 years ago by git

Commit: 1791d2750d21d69d028219e399ac95f757ab4a0fbba1345b54d043944b849dda0012625ffbecc0c5

Branch pushed to git repo; I updated commit sha1. New commits:

bba1345trac 20764 one detail

comment:5 Changed 7 years ago by git

Commit: bba1345b54d043944b849dda0012625ffbecc0c52f45b2862acfcbb0cdf40eaab15e47fac8d4811b

Branch pushed to git repo; I updated commit sha1. New commits:

2f45b28remove ParkingFunction_class from databases/findstat.py

comment:6 Changed 7 years ago by Mike Zabrocki

Hi Frédéric, I approve of the update and what you have in mind but there is more work to do here. Do you propose to deprecate the old input methods (labeled Dyck word, labeling/area sequence)? Should we add methods from_labeled_dyckword, etc. There should definitely be some documentation in class ParkingFunction. What do you propose to do with ParkingFunction_old?

comment:7 Changed 7 years ago by Mike Zabrocki

see also #16595

comment:8 Changed 4 years ago by Frédéric Chapoton

Keywords: parking added

comment:9 Changed 22 months ago by Frédéric Chapoton

Milestone: sage-7.3sage-duplicate/invalid/wontfix
Status: newneeds_review

can we also close as a duplicate of #15216 ?

comment:10 Changed 22 months ago by Travis Scrimshaw

Authors: Frédéric Chapoton
Branch: public/20764
Commit: 2f45b2862acfcbb0cdf40eaab15e47fac8d4811b
Reviewers: Frédéric Chapoton
Status: needs_reviewpositive_review

Indeed.

comment:11 Changed 22 months ago by Frédéric Chapoton

Resolution: duplicate
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.