Opened 3 years ago

Closed 3 years ago

#20752 closed defect (wontfix)

Wrong simplification in symbolic trigonometry involving fractions

Reported by: tmonteil Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: rws Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by tmonteil)

As reported in this ask question, Sage makes wrong simplifications in symbolic trigonometry involving fractions:

sage: cos(pi+pi*1/42)
cos(1/42*pi)

While it should be -cos(1/42*pi).

Change History (10)

comment:1 Changed 3 years ago by rws

Same with sin(pi+pi/42).

comment:2 Changed 3 years ago by tmonteil

I do not have intermediate versions of Sage with me, but i confirm that it is a regression since on Sage 5.12, we have:

sage: cos(pi+pi*1/42)
cos(43/42*pi)
sage: sin(pi+pi/42)
sin(43/42*pi)

comment:3 Changed 3 years ago by rws

No, the changes were just a few months ago, will get to it tomorrow.

comment:4 follow-up: Changed 3 years ago by tmonteil

More precisely, on a 7.2.beta4 version of Sage which i can reach by ssh, it works well:

sage: cos(pi+pi*1/42)
cos(43/42*pi)
sage: sin(pi+pi*1/42)
sin(43/42*pi)

So the regression is very recent, could it be due to the last update of pynac/ginac ?

comment:5 Changed 3 years ago by tmonteil

  • Description modified (diff)
  • Summary changed from Wrong simplification in symbolic trigonometry to Wrong simplification in symbolic trigonometry involving fractions

comment:6 Changed 3 years ago by tmonteil

  • Component changed from porting: Solaris to symbolics

comment:7 in reply to: ↑ 4 Changed 3 years ago by kcrisman

So the regression is very recent, could it be due to the last update of pynac/ginac ?

Almost certainly so. See e.g. this bug, though I assume it is a different particular one.

comment:8 Changed 3 years ago by rws

  • Milestone changed from sage-7.3 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

This is fixed and doctested in #20742.

comment:9 Changed 3 years ago by rws

  • Status changed from needs_review to positive_review

comment:10 Changed 3 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed

Determined to be invalid/duplicate/wontfix (closing as "wontfix" as a catch-all resolution).

Note: See TracTickets for help on using tickets.