Opened 13 years ago

Closed 13 years ago

#2068 closed defect (fixed)

[with spkg] zlib -- not picking up the right zlib when building libpng

Reported by: was Owned by: mabshoff
Priority: major Milestone: sage-2.10.2
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Hi,

libpng-1.2.22.p5 added this in spkg-install:
LDFLAGS="-L\"$SAGE_LOCAL/lib\" $LDFLAGS"

I tried the following modification:
LDFLAGS="-L$SAGE_LOCAL/lib $LDFLAGS"
and it worked.

The problem is that quoting the arg of -L seems still wise as the path
could contain a space but it seems it interferes with the (eval
"$ac_link") 2>conftest.er1  in src/configure.
E.g. the original LD_FLAGS definition works if we use instead: (eval
bash -c \"$ac_link\") 2>conftest.er1

Change History (2)

comment:1 Changed 13 years ago by mabshoff

  • Summary changed from zlib -- not picking up the right zlib when building libpng to [with spkg] zlib -- not picking up the right zlib when building libpng

An updated spkg can be found at

http://sage.math.washington.edu/home/mabshoff/release-cycles-2.10.2/alpha0/libpng-1.2.22.p5.spkg

Compile tested on Linux & OSX.

Cheers,

Michael

comment:2 Changed 13 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from new to closed

Merged in Sage 2.10.2.alpha0

Note: See TracTickets for help on using tickets.