Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#20625 closed defect (fixed)

PyPI updates

Reported by: vbraun Owned by:
Priority: major Milestone: sage-7.3
Component: packages: standard Keywords:
Cc: fbissey Merged in:
Authors: Volker Braun Reviewers: François Bissey
Report Upstream: N/A Work issues:
Branch: 6480581 (Commits) Commit:
Dependencies: Stopgaps:

Description (last modified by vbraun)

Automatic updates

Flask AutoIndex? has a new mandatory dependency on "future", added.

Change History (23)

comment:1 Changed 4 years ago by vbraun

  • Branch set to u/vbraun/pypi_updates

comment:2 Changed 4 years ago by vbraun

  • Cc fbissey added
  • Commit set to 6d5933e09e658b12a0cf636235c96a0bf699e9f6
  • Description modified (diff)

New commits:

6d5933eVarious updates from PyPI

comment:3 follow-up: Changed 4 years ago by fbissey

Weird bunch I just updated my sage-on-gentoo install to newer notebook and nbconvert than in sage. ipywidgets was just upped to 5.1.3 there and it pulled a new dependency widgetsnbextension, do you see it as being only optional?

comment:4 Changed 4 years ago by vbraun

Breaks sagenb with RuntimeError: working outside of application context

sage -t --long local/lib/python2.7/site-packages/sagenb/notebook/cell.py  # 2 doctests failed
sage -t --long local/lib/python2.7/site-packages/sagenb/notebook/worksheet.py  # 2 doctests failed
sage -t --long local/lib/python2.7/site-packages/sagenb/notebook/notebook.py  # 8 doctests failed
sage -t --long local/lib/python2.7/site-packages/sagenb/notebook/challenge.py  # 13 doctests failed
sage -t --long local/lib/python2.7/site-packages/sagenb/notebook/template.py  # 4 doctests failed

comment:5 Changed 4 years ago by fbissey

werkzeug, and flask_* are only used by sagenb, twisted too probably. In this particular case I am ok to let them rot a bit until we remove sagenb and remove them too.

comment:6 Changed 4 years ago by git

  • Commit changed from 6d5933e09e658b12a0cf636235c96a0bf699e9f6 to 89548ac0043a0d1d62144aae9b8997934a46444a

Branch pushed to git repo; I updated commit sha1. New commits:

89548acRevert flask_babel update

comment:7 Changed 4 years ago by vbraun

  • Status changed from new to needs_review

Leaving out the apparently problematic flask_babel update, now tests pass

comment:8 Changed 4 years ago by vbraun

I opened #20627 for flask-babel

comment:9 Changed 4 years ago by fbissey

  • Reviewers set to François Bissey
  • Status changed from needs_review to positive_review

OK, let's go with it. I'll have a look at flask_babel.

comment:10 in reply to: ↑ 3 Changed 4 years ago by jdemeyer

  • Status changed from positive_review to needs_info

Replying to fbissey:

Weird bunch I just updated my sage-on-gentoo install to newer notebook and nbconvert than in sage. ipywidgets was just upped to 5.1.3 there and it pulled a new dependency widgetsnbextension, do you see it as being only optional?

Good point.

comment:11 Changed 4 years ago by jdemeyer

I don't like these mindless mass-upgrade tickets since it gives a false impression that we can just upgrade without thinking about the consequences.

Especially for Jupyter-related packages, we really need to actually run Jupyter and check that stuff still works. It's not clear whether the author and/or reviewer of this ticket did that. Doctests are not sufficient for this.

comment:12 Changed 4 years ago by fbissey

Touché !

Last time I didn't insist on a dependency we had to add it later.

Volker works on the assumptions that I may have add contact with most of those in sage-on-gentoo. Which used to be the case but since Volker has accelerated the rate it's a mixed bag.

We are now in a situation where Volker has just merged ipython-4.2.0 and I don't have it. On the other hand I have notebook and nbconvert 4.2.0 and it is nowhere to be seen here.

As to flask_babel it has been in portage since the 11th of May but no user on ~arch complained about the problem Volker sees (may be not enough people running the doctests on ~arch).

To go back to properly testing jupyter do you have something in mind? A set of notebooks that would have to be tested or something?

comment:13 Changed 4 years ago by vbraun

Dependency checking is broken in ipywidgets, I opened https://github.com/ipython/ipywidgets/issues/597

comment:14 Changed 4 years ago by vbraun

IMHO if we need E2E testing for jupyter then we should have automated testing for it. Delaying package updates until some nebulous manual incantations are performed is not a sane workflow.

comment:15 Changed 4 years ago by jdemeyer

A good start would be actually running the testsuites of those Python packages. Related: #19680.

In any case, as long as we do not have automated testing, those "nebulous manual incantations" will need to be performed.

comment:16 Changed 4 years ago by vbraun

Upstream says that its not a bug that they don't check dependencies....

comment:17 Changed 4 years ago by git

  • Commit changed from 89548ac0043a0d1d62144aae9b8997934a46444a to bdcb06349a6ca553d5dcea16e972b83a97ea1e88

Branch pushed to git repo; I updated commit sha1. New commits:

bdcb063Add widgetsnbextension

comment:18 Changed 4 years ago by vbraun

  • Status changed from needs_info to needs_review

I tired a jupyter widget and it works.

comment:19 Changed 4 years ago by fbissey

  • Status changed from needs_review to positive_review

ok, let's move this again and then work on #19680 and any other stuff needed for testing.

comment:20 Changed 4 years ago by vbraun

Apparently races against setuptools installation

IOError: zipimport: can not open file /home/buildbot/slave/sage_git/build/local/lib/python2.7/site-packages/setuptools-20.3.1-py2.7.egg

real	0m0.182s
user	0m0.080s
sys	0m0.080s
************************************************************************
Error installing package widgetsnbextension-1.2.2

comment:21 Changed 4 years ago by git

  • Commit changed from bdcb06349a6ca553d5dcea16e972b83a97ea1e88 to 6480581b09047a3f427ce2c015223aadcef176f6
  • Status changed from positive_review to needs_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. New commits:

6480581Do not install widgetsnbextension parallel with setuptools

comment:22 Changed 4 years ago by vbraun

  • Branch changed from u/vbraun/pypi_updates to 6480581b09047a3f427ce2c015223aadcef176f6
  • Resolution set to fixed
  • Status changed from needs_review to closed

comment:23 Changed 4 years ago by jdemeyer

  • Commit 6480581b09047a3f427ce2c015223aadcef176f6 deleted

This broke ipywidgets, see #21256.

Note: See TracTickets for help on using tickets.