Opened 5 years ago

Closed 4 years ago

#20580 closed enhancement (duplicate)

Make __doc__ a descriptor instead of using _sage_doc_()

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: documentation Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

Instead of supporting a custom _sage_doc_() method, we should just use standard Python tricks to change __doc__.

This actually breaks in Cython due to some Cython bug(?) with decorators. While trying to fix that bug, I broke @staticmethod because of an unrelated bug http://trac.cython.org/ticket/880

Change History (3)

comment:1 Changed 5 years ago by jdemeyer

  • Summary changed from Make __doc__ a descriptor instead of _sage_doc_ to Make __doc__ a descriptor instead of using _sage_doc_()

comment:2 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:3 Changed 4 years ago by jdemeyer

  • Authors Jeroen Demeyer deleted
  • Milestone changed from sage-7.3 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to closed

Duplicate of #22611

Note: See TracTickets for help on using tickets.