Opened 6 years ago

Closed 6 years ago

#20549 closed defect (fixed)

py3 print in geometry folder

Reported by: Frédéric Chapoton Owned by:
Priority: major Milestone: sage-7.2
Component: python3 Keywords:
Cc: Merged in:
Authors: Frédéric Chapoton Reviewers: Jori Mäntysalo
Report Upstream: N/A Work issues:
Branch: 6d7190b (Commits, GitHub, GitLab) Commit: 6d7190bca4ab8bf7e7c857a36c4ab7e7b9c3daf0
Dependencies: Stopgaps:

Status badges

Description

another small step for python3 print

Change History (18)

comment:1 Changed 6 years ago by Frédéric Chapoton

Branch: public/20549
Commit: b4f0031941e90d73a8c9d66d527234c37681f3fd
Status: newneeds_review

New commits:

b4f0031python3 print in geometry folder

comment:2 Changed 6 years ago by Jori Mäntysalo

Reviewers: Jori Mäntysalo

One more ticket...

comment:3 Changed 6 years ago by Jori Mäntysalo

Status: needs_reviewneeds_work

Fails in geometry/riemannian_manifolds/parametrized_surface3d.py:

Failed example:
    numerical_integral(L.substitute(a=2, b=1.5, c=1),0,1)[0]
Expected:
    2.00127905972
Got:
    2.001279059716735

comment:4 Changed 6 years ago by Jori Mäntysalo

A side note: For example geometry/triangulation/point_configuration.py still has old-style prints. You might want to add a note to the description of the ticket.

comment:5 Changed 6 years ago by git

Commit: b4f0031941e90d73a8c9d66d527234c37681f3fd3fea19f02c6ae2d4a14c340cf671a9000caca2d3

Branch pushed to git repo; I updated commit sha1. New commits:

3fea19fadding a tolerance

comment:6 Changed 6 years ago by Jori Mäntysalo

?? I am now on another machine and got in geometry/toric_plotter.py an error:

File "src/sage/geometry/toric_plotter.py", line 475, in sage.geometry.toric_plotter.ToricPlotter.plot_lattice
Failed example:
    tp.plot_lattice()
Expected:
    Graphics object consisting of 1 graphics primitive
Got:
    doctest:590: RichReprWarning: Exception in _rich_repr_ while displaying object: int() argument must be a string or a number, not 'NoneType'
    Graphics object consisting of 1 graphics primitive

I think I did not see that yesterday.

comment:7 Changed 6 years ago by Frédéric Chapoton

yes, this is also found by the patchbots, and I do not yet know how to this this one.

comment:8 Changed 6 years ago by git

Commit: 3fea19f02c6ae2d4a14c340cf671a9000caca2d334042f428fbec98e3616e270fb1f3da5af05348b

Branch pushed to git repo; I updated commit sha1. New commits:

34042f4python3 print in geometry, some other prints

comment:9 Changed 6 years ago by Jori Mäntysalo

Everything seems to be OK, counting out that one error.

comment:10 Changed 6 years ago by Frédéric Chapoton

That needs to be solved, nevertheless. I will try to investigate. Jori, if you like, could you please look at #20505 ?

comment:11 in reply to:  10 Changed 6 years ago by Jori Mäntysalo

Replying to chapoton:

That needs to be solved, nevertheless.

Of course.

Jori, if you like, could you please look at #20505 ?

Why not, but Vincent seems to already be reviewing it.

comment:12 Changed 6 years ago by git

Commit: 34042f428fbec98e3616e270fb1f3da5af05348b6d7190bca4ab8bf7e7c857a36c4ab7e7b9c3daf0

Branch pushed to git repo; I updated commit sha1. New commits:

6d7190bpython3 print in geometry, solving the remaining doctest issue

comment:13 Changed 6 years ago by Frédéric Chapoton

Status: needs_workneeds_review

I think I have solved the doctest problem, but it is not clear what it has to do with "print".

comment:14 Changed 6 years ago by Jeroen Demeyer

I really don't like your last commit because it looks very unrelated to the topic of this ticket.

comment:15 Changed 6 years ago by Frédéric Chapoton

ok, ok. I see your point. But still this doctest failure was not there before. It is caused by the attribute point_size not being initialized in the object "tp".

I would rather not cure all diseases of sage at the same time..

What solution do you propose ?

Last edited 6 years ago by Frédéric Chapoton (previous) (diff)

comment:16 in reply to:  14 Changed 6 years ago by Jori Mäntysalo

Replying to jdemeyer:

I really don't like your last commit because it looks very unrelated to the topic of this ticket.

Would it be OK, if Frédéric adds a note of this to description?

comment:17 Changed 6 years ago by Jori Mäntysalo

Status: needs_reviewpositive_review

It makes no sense to wait for this. This kind of trivial but long patch is just waiting to get a conflict with some other ticket. The issue solved by Frédéric with ​6d7190b can be later taken as a separate ticket if needed.

comment:18 Changed 6 years ago by Volker Braun

Branch: public/205496d7190bca4ab8bf7e7c857a36c4ab7e7b9c3daf0
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.